
Creare e animare molecole  

Chimera 

VirtualDub2: dai frames ai videoclip 

PhotoScape e le GIF animate 

IrfanView e la conversione a lotti (Batch) dei frames 

Chimera (ancora) 

Jmol 

VMD 

Sirius 

Molby 

PyMol 

BALLView 

IQmol  (Q-Chem) 

Gabedit 

OpenMM Zephyr e Gromacs 

Force Field Explorer (FFE) e Tinker 

Molden 

MoCalc 2012 (Mopac – FireFly  – Gamess – NWChem) 

Molekel 

Avogadro 

QuteMol 

CueMol 

MolGif 

NOC 

Discovery Studio Visualizer 

ACD Chemsketch 

CYLview 

PMV (Python Molecular Viewer) 

Yasara 

NB.  Le animazioni sono visibili solo nella versione HTML 

 

In questo tutorial vedremo come utilizzare i software di modellazione chimica freeware per costruire 

molecole e creare videoclip molecolari. 



Alcuni di questi programmi producono direttamente i videoclip (in genere in formato AVI, MP4 o GIF 

animato), altri producono i singoli frames (immagini-fotogramma in genere in formato BMP, JPEG, PNG o 

GIF), i quali devono essere poi convertiti in un videoclip.  

In realtà, anche quando il programma produce direttamente il videoclip, genera sempre i frames che poi 

cancella e, a mio modo di vedere conviene, se possibile,  fare in modo che i frames non vengano cancellati 

e procedere sempre ed in ogni caso alla conversione manuale che ci permette di avere un maggior 

controllo sulla qualità finale del videoclip (ad esempio ci permette di settare il bitrate). 

La prima cosa di cui abbiamo bisogno è ovviamente di una molecola. Vi sono molti modi diversi per 

procurarsi una molecola ed è per questo che inizieremo dal programma UCSF Chimera 1.14 il quale è 

estremamente versatile nell’ottenere molecole. 

I dati che descrivono la struttura di una molecola sono contenuti in un file di testo che, nella maggior parte 

dei casi, riporta le coordinate cartesiane (x, y, z) degli atomi che compongono la struttura molecolare. 

I formati sono moltissimi. Tra i più semplici vi è il formato XYZ (con estensione .xyz) di cui vediamo di 

seguito il contenuto relativo ad una molecola d’acqua H2O 

3 
O         -0.56829        0.83952        0.00000 
H          0.40171        0.83952        0.00000 
H         -0.89162        1.22612        0.82879 
 

 

e ad una di ammoniaca NH3 

4 
N         -2.65759        1.10817        0.00000 
H         -1.63759        1.10817        0.00000 
H         -2.99759        1.19832        0.95743 
H         -2.99760        0.23393       -0.40064 
 

Chimera 

Chimera legge un numero enorme di formati molecolari. Se dunque ci siamo procurati o abbiamo creato un 

file molecolare ci sono buone probabilità che Chimera sia in grado di aprirlo. In caso contrario possiamo 

utilizzare il programma OpenBabel capace di convertire uno nell’altro un numero impressionante di diversi 

formati molecolari. 

Chimera ci permette inoltre di scaricare molecole da numerosi database chimici presenti in Rete, a patto 

ovviamente di conoscere la sigla con cui la molecola è classificata in quel determinato database. 

Se la molecola è una proteina il formato del file è tipicamente PDB (Protein Data Bank).  Proviamo ad 

esempio a caricare il Lisozima, un enzima che digerisce la capsula batterica e che si trova anche nella saliva 

umana, dove agisce come un blando disinfettante. Una veloce ricerca sul WEB inserendo la voce “Lisozima 

PDB” ci fornisce per il lisozima umano il codice PDB = 1REX. 



In Chimera clicchiamo il menù “File > Fetch by ID..”, selezioniamo la voce “PDB”, inseriamo il codice 

“1REX”, clicchiamo su “Set download directory” per definire la cartella nella quale verrà scaricato il file 

PDB” e infine clicchiamo su “Fetch”. 

 

Ed ecco il risultato 

 

Coloriamo le strutture secondarie cliccando su “Tools > Depiction > Color Secondary Structure” 

 



 

 

Se invece la molecola non è una proteina possiamo scaricarla dal database PubChem, a patto di conoscere 

il numero identificativo CID della molecola di nostro interesse. Proviamo ad esempio a caricare il 

Paracetamolo (Tachipirina). Una veloce ricerca sul WEB inserendo la voce “Paracetamolo PubChem CID” ci 

fornisce il codice PubChem CID = 1983.   

Usiamo sempre il menù “File > Fetch by ID..”, ma selezioniamo  la voce “PubChem”, inseriamo il codice 

“1983” e clicchiamo su “Fetch”. 



 

Ed ecco il risultato 

 

***** 

Un altro modo per ottenere una molecola in Chimera è conoscerne il codice SMILES (Simplified Molecular 

Input Line Entry System) una breve stringa di testo in grado di descrivere la struttura molecolare. Anche le 

stringhe SMILES delle molecole sono facilmente recuperabili in internet. 

Proviamo ad esempio a caricare la Caffeina. Una veloce ricerca sul WEB inserendo la voce “Caffeina 

SMILES” ci fornisce la stringa SMILES  CN1C=NC2=C1C(=O)N(C(=O)N2C)C.   

Usiamo  il menù “Tools > Structure Editing > Build Structure”. 

 



 

e sulla finestra che compare selezioniamo la voce “SMILES string”, incolliamo la stringa SMILES che 

abbiamo trovato e clicchiamo su “Apply”. 

 

Ed ecco il risultato 

 



Una volta ottenuta la molecola è ovviamente possibile salvarla nel formato PDB tramite il menù “File > Save 

PDB..” o nel formato Tripos-Sybyl tramite il menu “File > save mol2…” in  modo da poterla utilizzare con 

altri programmi. 

***** 

In alternativa Chimera ci permette di costruire la molecola ex novo. In realtà, come vedremo, esistono 

programmi che presentano Editor molecolari più semplici che permettono di costruire molecole in modo 

decisamente più agevole di quanto non faccia Chimera. 

Per costruire una proteina ex novo usiamo  ancora il menù “Tools > Structure Editing > Build Structure” e 

nella finestra che compare selezioniamo la voce “peptide”.  Nella finestra “Peptide sequence” dobbiamo 

inserire una sequenza di amminoacidi usando per ciascuno di essi la corrispondente sigla. 

Amminoacido  Lettera  

Alanina A 

Arginina R 

Asparagina N 

Acido aspartico D 

Cisteina C 

Acido glutammico E 

Glutammina Q 

Glicina G 

Istidina H 

Isoleucina I 

Leucina L 

Lisina K 

Metionina M 

Fenilalanina F 

Prolina P 

Serina S 

Treonina T 

Triptofano W 

Tirosina Y 

Valina V 

 

Ad esempio, per una sequenza Alanina-Cisteina-Glicina-Metionina-Istidina dovremo inserire la sequenza 

ACGMH e poi cliccare su “Apply”. 



 

Si aprirà un’ulteriore finestra che ci permetterà di regolare gli angoli Φ e Ψ che caratterizzano le diverse 

strutture secondarie (alfa elica, foglietto beta etc). Di “defoult” gli angoli sono quelli dell’alfa elica. 

 

Clicchiamo su “Apply” ed il risultato è il seguente peptide avvolto ad alfa elica 

 

In modo simile è possibile costruire un DNA o un RNA. Sempre dal menù “Tools > Structure Editing > Build 

Structure” nella finestra che compare selezioniamo la voce “Helical DNA/RNA”.  Nella finestra “Sequence” 

dobbiamo inserire una sequenza di Nucleotidi usando per ciascuno di essi la corrispondente sigla. 

DNA → Adenina (A) Timina (T) Guanina (G) Citosina (C) 



RNA → Adenina (A) Uracile (U) Guanina (G) Citosina (C) 

 

Proviamo infine a costruire una molecola disegnandola pezzo per pezzo. In questo caso l’editor di Chimera 

non è dei più semplici e richiede la conoscenza da parte dell’utente della geometria (tetraedrica, trigonale, 

lineare) e del numero di legami che i diversi elementi chimici devono presentare all’interno di una certa 

molecola. Clicchiamo sempre il menù “Tools > Structure Editing > Build Structure” e nella finestra che 

compare selezioniamo “Atom” e clicchiamo su “Apply”. 

 

Nella finestra di visualizzazione comparirà un atomo di He, già selezionato, che rappresenta l’inizio della 

nostra nuova molecola e che noi andremo a cambiare. 

 



Ritorniamo alla finestra “Build Structure” e, lasciando selezionata la voce “atom” cambiamo il menù in alto 

da “Start structure” a “Modify Structure” che ci permette di cambiare l’atomo (o gli atomi selezionati) in 

altri tipi di atomi (altri elementi chimici).  

 

Nella Casella “Change selected atoms to…” ci viene proposto il Carbonio (C) con 4 legami (4 bonds) e una 

geometria tetraedrica. Accettiamo la proposta e clicchiamo su “Apply”. L’atomo di He si trasforma in un 

atomo di C con 4 legami già saturati da Idrogeno: una molecola di metano CH4. 

 

Selezioniamo uno degli atomi di Idrogeno con un “ctrl + clic sinistro” (clicchiamo sull’idrogeno col il tasto 

sinistro del mouse mentre teniamo premuto il tasto Control della tastiera). L’idrogeno selezionato si 

illumina di verde. Nella finestra “Build Structure” clicchiamo ancora “Apply” per sostituire l’idrogeno 

selezionato con un atomo di C con 4 legami già saturati da Idrogeno: una molecola di etano CH3 CH3 



 

Selezioniamo un altro atomo di idrogeno e sostituiamolo con un atomo di Carbonio con 3 legami ed una 

geometria Trigonale planare. Nella Casella “Change selected atoms to…” cambiamo il tipo di atomo di C e 

poi clicchiamo “Apply”. 

 

La molecola ottenuta non è corretta. Un Carbonio trigonale deve necessariamente essere impegnato in un 

doppio legame (ad esempio con un atomo di Ossigeno o con un altro atomo di Carbonio Trigonale). 

Selezioniamo dunque uno dei suoi idrogeni e sostituiamolo con un altro atomo Trigonale. La molecola 

ottenuta è l’1-butene (un alchene).  

Purtroppo Chimera non mostra i legami multipli (doppi e tripli). 

 



Ora sostituiamo uno degli idrogeni terminali dell’alchene con un ossidrile (-OH). L’Ossigeno ossidrilico è 

Tetraedrico ma ha solo due legami. Modifichiamo quindi la casella “Change selected atoms to..” 

selezionando “Element = O” “Bonds = 2” e “Geometry = Tetrahedral” e, dopo aver selezionato l’atomo di 

Idrogeno da sostituire, clicchiamo su “Apply”. 

 

 

Ora sostituiamo due degli idrogeni terminali dell’alchene con due gruppi amminici (-NH2). L’Azoto amminico 

è Tetraedrico ma ha solo tre legami. Modifichiamo quindi la casella “Change selected atoms to..” 

selezionando “Element = N” “Bonds = 3” “Geometry = Tetrahedral”. 

Per selezionare due atomi di idrogeno clicchiamoci sopra con il tasto sinistro, prima su uno e poi sull’altro, 

tenendo contemporaneamente premuto i tasti Control-Shift  e, dopo aver selezionato i due atomi di 

idrogeno da sostituire, clicchiamo su “Apply”. 

 

Trasformiamo infine uno dei due gruppi amminici in un gruppo nitro (-NO2). Selezioniamo entrambi gli 

atomi di idrogeno legati all’Azoto e sostituiamoli con un Ossigeno con un solo legame. 



 

Salviamo la molecola in formato Sybyl (mol2) tramite il menù “File > save mol2..” e riapriamola con un altro 

programma per vedere se viene letta correttamente. Possiamo usare ad esempio ArgusLab 4.01 che è in 

grado di visualizzare i legami multipli e persino la risonanza all’interno del gruppo nitro. 

 

Ora che abbiamo visto come procurarci una molecola proviamo ad animarla e a trasformarla in un 

videoclip. 

***** 

Tuttavia, prima di iniziare a lavorare con l’animazione è opportuno regolare la dimensione della finestra che 

determinerà la dimensione in pixel (larghezza e altezza) del videoclip. In generale sarebbe opportuno che 

larghezza e altezza fossero entrambe multiple di 2 per non dare problemi ad alcuni codec video (in 

particolare per il formato mp4). Nell’immagine che segue abbiamo ricaricato il Lisozima e la finestra è stata 

ridimensionata a 416 x 328 pixels (i valori appaiono alla base della finestra mentre si ridimensiona). 



 

Nel caso in cui il ridimensionamento manuale sia difficoltoso è possibile aprire la Console a Linea di 

Comando cliccando sul menù “Tools > General Controls > Command Line” e digitare il comando 

“windowsize” seguito dai valori desiderati di larghezza e altezza in pixels e dal tasto “invio” da tastiera. 

 

Usando il mouse disponiamo ora la molecola nella posizione che desideriamo: 

- Clic sinistro + trascina = rotazione 

- Clic destro + trascina = zoom (movimento asse z) 

- Clic centrale + trascina = traslazione (movimento piano xy) 

 

Ora possiamo aprire la finestra “Animazione” cliccando sul menù “Tools  > Utilities > Animation” 



 

Clicchiamo sul bottone verde in alto a sinistra con il segno + per aggiungere la prima scena (un’immagine 

della molecola come si presenta nella finestra del programma).  

 

Clic destro sulla scena  per aggiungerla alla Timeline 

 

Clic sinistro sull’icona “Roll” per selezionare la rotazione come tipo di animazione e  poi clic sinistro sul 

segno + in basso a sinistra per aggiungere l’animazione Roll alla Timeline 



 

Tasto destro sull’icona della rotazione nella Timeline e dal menù pop-up selezionare “Property” per far 

comparire la finestra che ci permetterà di definire le caratteristiche della rotazione. 

 

Nella casella “Duration in frames” dobbiamo inserire il numero di frames utilizzati dall’animazione per 

effettuare una rotazione completa di 360°. Poiché il videoclip avrà un framerate di 25 fps (frame per 

secondo), se impostiamo 25 frames la rotazione completa avverrà in 1 secondo, se impostiamo 50 frames la 

rotazione avverrà in 2 secondi, con 75 frames avverrà in 3 secondi e così via. Per molecole non troppo 

grandi possiamo impostare 75 frames (3 secondi per una rotazione completa). 

Nella Scheda “Parameters” possiamo stabilire l’angolo di rotazione (lasciamo 360°) e l’asse intorno al quale 

la rotazione avverrà (x, y, z). Clicchiamo su “Okay” e ritorniamo alla finestra “Animation”. 

Qui clicchiamo prima su “Play” per controllare che l’animazione avvenga correttamente e poi su “Record”. 



 

Nella finestra “Record Animation” che si apre: 

1) Su “Folder” scegliamo la cartella in cui salvare il videoclip 

2) In “File name” scriviamo il nome del file che verrà salvato come videoclip 

3) In “File type” scegliamo il formato video 

4) In “Rendering” decidiamo se i fotogrammi verranno generati da Chimera o da Povray (un software 

per il raytracing) 

5) Clicchiamo infine su “Advanced Options” per accedere ad ulteriori opzioni  

 

 

In “Advanced Options” 

1) In “Quality” scegliamo la qualità del videoclip che stiamo per produrre. A maggior qualità 

corrisponde naturalmente una maggior dimensione del file. Una qualità “Good” o addirittura 

“Medium” può dare dei buoni risultati, paragonabili ai livelli di qualità più elevati, ma generando 

file decisamente meno ingombranti. 

2) In “Image format” scegliamo il formato grafico dei frames che verranno generati. È consigliabile il 

formato PNG 



3) In “Additional encoding options” scriviamo “resetMode keep”. Questo fa in modo che alla fine del 

lavoro Chimera non cancelli tutti I singoli frames che ha generato nella cartella “C:\Temp”. In 

questo modo potremo eventualmente utilizzarli per ottenere un video clip con le caratteristiche da 

noi desiderate. 

4) clicchiamo infine su “Record” per avviare il lavoro 

 

Ed ecco il risultato, un file MP4 di 570 kB codificato in qualità “highest” (bitrate = 1531 kps) 

Lisozima_highest.mp4 

Mentre il seguente è un file MP4 di 306 kB codificato in qualità “medium” (bitrate = 820 kbs) utilizzando 

Povray 

Lisozima_medium_pov.mp4 

Torna all’indice 

VirtualDub2: dai frames ai videoclip 

Se vogliamo un maggior controllo sul risultato finale dobbiamo utilizzare I frames in formato PNG che 

Chimera ha lasciato nella cartella c:\Temp. Per trasformarli in un video utilizziamo il programma 

VirtualDub2. I frames sono numerati da 00000 a 00075. I frames 00000 e 00001 sono uguali ed il frame 

00000 va cancellato. Sarà sufficiente caricare con Virtualdub2 il frame 00001 e tutti i successivi verranno 

automaticamente caricati. 

 

Dal menù “Video” selezioniamo “Full processing Mode” 



 

Dallo stesso menù clicchiamo su “Frame rate…” e impostiamo a 25 fps  

 

Dallo stesso menù clicchiamo su “Compression…” e scegliamo ed impostiamo il codec. Selezioniamo il 

codec “x264 8 bit” (si noti che nella finestra a destra si avvisa che larghezza e altezza del video devono 

essere multipli di 2) e poi clicchiamo su “Configure”.  

 

 

Dopo aver impostato il “Tuning” su “Animation”, abbiamo due opzioni: impostare il livello di qualità o 

impostare il bitrate 

1) se impostiamo il livello di qualità allora lasciamo che il codec scelga il bitrate più opportuno. In tal 

caso in “Rate control” selezioniamo “Single pass – quantizer-based” e decidiamo il valore del 

“Quantizer” che può andare da 1 (ottimo) a 51 (pessimo). Un valore consigliato è di solito 23 (che 

corrisponde al livello “Medium” di Chimera) 

 



 

 

 

 

 

2) possiamo decidere noi il bitrate. In tal caso in “Rate control” selezioniamo “Single pass – bitrate-

based” e decidiamo il valore del Bitrate medio. Il calcolo del miglior bitrate per un certo video 

dipende dalle dimensioni grafiche del video (larghezza x altezza), dal tipo di video (animazione, film 

con scene veloci o lente etc) e dall’efficienza del Codec. Ogni codec video utilizza tipicamente un 

certo numero di bit per ciascun pixel che deve codificare (bpp = bit per pixel), a volte detto fattore 

di qualità. Ad esempio il codec x264-AVC lavora bene tra 0.1 e 0,3 bpp (in relazione al tipo di 

video). Utilizzando un valore medio pari a 0,2 il calcolo del bitrate è il seguente 

Bitrate = larghezza x altezza x framerate x 0.2 

Bitrate = 416 x 328 x 25 x 02 = 682.240 bit/s ≈ 680 kbit/s  

 

Nel caso i frames abbiano larghezza e/o altezza con valori dispari è necessario “ritagliarli” togliendo loro un 

pixel. Clicchiamo sul menù “Video>Filters..” e nella scheda che si apre clicchiamo su “Add..” 



 

Nella finestra che si apre scegliamo il filtro “Crop”. Si aprirà un’altra finestra in cui sarà possibile indicare di 

quanti pixel ritagliare il video a destra, sinistra, sotto e sopra. Nel nostro caso non è necessario poiché 

entrambe le dimensioni sono pari (416 x 238). Nel caso la larghezza fosse dispari sarebbe necessario 

inserire 1 o su Left o su Right. Nel caso l’altezza fosse dispari sarebbe necessario inserire 1 o su Top o su 

Bottom. E poi dare OK. 

 

A questo punto clicchiamo sul menù “File>Save video..” e nella finestra che si apre scegliamo in “salva 

come..” il formato “MP4 MPEG-4 part 14” 



 

Ed ecco il risultato, un file MP4 di 253 kB codificato a bitrate = 690 kps. 

Lisozima_Virtualdub.mp4 

Torna all’indice 

PhotoScape e le GIF animate 

I frames PNG possono essere utilizzati anche per creare una Gif animata che, rispetto ai file mp4, si integra 

con più facilità in una pagina HTML per la visualizzazione in Internet, anche se ovviamente la qualità è 

decisamente inferiore e le dimensioni del file maggiori. 

Per trasformare i frames in una gif animata usiamo Photoscape 3.7. Apriamo la scheda “Tutto per Gif”  

 

Selezioniamo tutti i frames PNG e trasciniamoli in Photoscape all’interno della scheda “Tutto per Gif”. 



 

Per avere un’animazione fluida clicchiamo su “Cambia tempi” e impostiamo un delay (intervallo tra un 

frame a l’altro) pari a 5 centesimi di secondo. Clicchiamo su “OK” e poi su “Salva”. 

 

Ed ecco il risultato, un file molto pesante delle dimensioni di 1,2 MB 

Lisozima_256.gif 

Se vogliamo un file più piccolo possiamo ridurne le dimensioni su Photoscape al 50%.   



 

Ed ecco il risultato, un file delle dimensioni di 420 kB 

Lisozima_256_50%.gif 

Torna all’indice 

IrfanView e la conversione a lotti (Batch) dei frames 

Per ottenere GIF animate più leggere è necessario diminuire il numero di colori dei frames da 256 a 16, 

utilizzando IrfanView 4.54. Clicchiamo sul menù “File > Batch Conversion/Rename…” di IrfanView. 

All’interno della finestra “Batch Conversion”: 

1) selezioniamo la voce “GIF – Compuserve GIF” in “Output format” 

2) selezioniamo “Use Advanced option” e Clicchiamo sul pulsante “Advanced”. Nella finestra che si 

aprirà selezioniamo “16 Colors” “use Floyd-Steinberg dithering” e “Use best color quality” 

 

3) Individuiamo e selezioniamo i file PNG da convertire in GIF 

4) Clicchiamo sul pulsante “Add” per aggiungere i file PNG selezionati alla finestra di Input 

5) Selezioniamo la cartella in cui verranno salvati i file GIF generati 

6) Avviamo la conversione con diminuzione del numero dei colori cliccando su “Start Batch” 

 



 

Carichiamo in Photoscape i file GIF generati e convertiamoli in GIF Animate a 16 colori come abbiamo fatto 

in precedenza per i frames PNG. Il risultato è un file da 742 kB (invece che da 1,2 MB) e un file di dimensioni 

grafiche ridotte del 50% di 265 kB (invece che 420 kB). 

Lisozima_16.gif    e   Lisozima_16_50%.gif 

Per avere file ancor più contenuti nelle dimensioni è necessario effettuare l’animazione in Chimera con un 

minor numero di frames. Ovviamente in tal caso l’animazione può risultare poco fluida ( a scatti). Si veda ad 

esempio la GIF animata seguente ottenuta con 36 frames (invece che con 75) con un delay di 8 centesimi di 

secondo (invece che 5) a 16 colori del peso di 340 kB 

Lisozima16_36_frames_delay8.gif 

Torna all’indice 

Chimera (ancora) 

Proviamo ora a costruire con Chimera un’animazione più complessa. Cerchiamo una proteina che contenga 

un gruppo non proteico (cofattore o gruppo prostetico), come ad esempio la Mioglobina, che contiene 

all’interno del suo avvolgimento il gruppo Eme, responsabile del trasporto dell’ossigeno. 

Una ricerca in Rete inserendo la voce “Myoglobin PDB” ci fornisce il codice PDB = 1MBN. Lo inseriamo nella 

ricerca “Fetch” di Chimera. Il risultato è il seguente (dopo aver colorato la struttura secondaria con “Tools > 

Depiction > Color Secondary Structure”) 



 

Apriamo la finestra “Animation (menu “Tools > Utilities > Animation”) e aggiungiamo la scena iniziale (clic 

sul segno + in alto a sinistra), aggiungendola anche alla Timeline (clic destro sulla scena “Add to Timeline”). 

Gli assegniamo una durata di 10 frames (clic destro > properties > 10 frames). 

Ora aggiungiamo alla Timeline una rotazione (Roll) assegnadogli una durata di 50 frames. 

Ora torniamo alla molecola, ruotiamola (clic sinistro + trascina) e zoomiamo sul gruppo Eme (clic destro + 

trascina) 

 

Visualizziamo il gruppo Eme in “Ball&Stick”. Prima lo selezioniamo, cliccando su  “Select > Residue > Hem” 

e poi “Actions > Atoms/Bonds > Ball & Stick”. Infine per deselezionarlo “CTRL+Clic sinistro” fuori dalla 

molecola.  Ora selezioniamo (CTRL+clic sinistro) l’atomo di Ferro al centro del gruppo Eme e lo visualizziamo  

in “spacefill” cliccando su “Actions > Atoms/Bonds > Sphere” 

 



              

 

Ora torniamo alla finestra “Animation” e aggiungiamo anche questa scena. Chimera provvederà a passare, 

dopo la rotazione, dalla prima scena alla seconda scena in modo fluido. Aggiungiamo alla Timeline la 

seconda scena un’altra volta in modo che una volta avvenuta la transizione dalla scena 1 alla scena 2, la 

scena 2 rimanga ferma per il numero di frames che gli assegniamo (clic destro > properties > 30 frames). 

Infine aggiungiamo alla Timeline nuovamente la scena 1 in modo che la molecola ritorni alla posizione 

iniziale e sia possibile farla girare in loop. L’animazione è composta da 130 frames: 10 per l’immagine 

iniziale, 50 per la rotazione, 20 per passare dall’immagine iniziale allo zoom sul gruppo Eme, 30 per il 

gruppo Eme fermo, altri 20 per ritornare dal gruppo Eme all’immagine iniziale. 

 

 

Questo è il risultato (580 kB)  utilizzando in Chimera un livello di qualità “Medium” 

Mioglobina.mp4 



Possiamo usare i frames PNG per ottenere una GIF animata con Irfanview (per convertire i PNG in GIF e 

diminuire a 16 il numero di colori) e  PhotoScape (per convertire i frames GIF in GIF Animata). In questo 

caso è possibile diminuire ulteriormente le dimensioni della gif animata poiché i 30 frames in cui 

l’animazione si ferma sul gruppo Eme sono tutti uguali. In Photoscape è possibile tenerne 1 e aumentarne il 

delay da 5 centesimi di secondo a 150 centesimi di secondo. 

Il risultato (con un resize del 50%) è il seguente (528 kB). Praticamente un file delle stesse dimensioni 

dell’MP4 con una qualità decisamente inferiore. 

Mioglobina_16colori 50%.gif 

***** 

Chimera permette di generare animazioni anche registrando “in diretta” le operazioni che l’utente effettua 

sulla molecola. Clicchiamo su “Tools > Utilities > Movie Recorder”. Si apre la finestra “Movie Recorder” 

dove possiamo settare alcuni parametri prima di iniziare la registrazione. 

 

1) In “Output format” il formato video con cui verrà codificata l’animazione 

2) In “Output file” il nome del file video che verrà generato e la cartella di destinazione 

3) In “Frame Options” possiamo definire la cartella in cui verranno registrati i frames, il loro formato 

grafico (PNG, JPEG etc) 

4) Se Impostiamo “true” in  “Save images on Reset” alla fine della codifica I frames non verranno 

cancellati e potremo riutilizzarli. 

5) In “Movie Option” possiamo definire la qualità dell’animazione scegliendo tra un bitrate variabile in 

cui viene definito il livello di qualità desiderato e un bitrate costante. 

6) A questo punto possiamo registrare, cliccando su “Record”, ciò che accade alla nostra molecola 

mentre la manipoliamo. È possibile anche interrompere la registrazione, cambiare molecola e 

riprendere la registrazione. 

7) Una volta terminata la registrazione clicchiamo su “”Make movie” 



Nel video clip successivo (127 kB) ho iniziato a manipolare una molecola di acido fosforico di cui ho trovato 

la stringa SMILES → OP(=O)(O)O in Rete inserendo la voce “Fosforico smiles”. Poi ho interrotto la 

registrazione ed ho ripreso costruendo una molecola di Metano, poi trasformata in Etano e poi in 1,2 

etandiolo, sostituendo due atomi di idrogeno con due ossidrili. 

molecole.mp4 (127kB) 

***** 

Chimera è infine in grado di generare animazioni a partire da traiettorie generate da simulazioni di 

dinamica molecolare prodotte da Chimera o da altri programmi. Tipicamente le simulazioni di dinamica 

molecolare studiano sia transizioni conformazionali (traiettorie) che vibrazioni locali. 

Il calcolo della traiettoria di un sistema molecolare, ossia delle transizioni conformazionali della molecola in 

funzione del tempo, determina come variano nel tempo le posizioni, le velocità e le accelerazioni degli 

atomi della molecola, trattati secondo un campo di forze (Force Field) che ne descrive le energie di legame. 

Chimera permette di eseguire simulazioni di Dinamica molecolare (e quindi di calcolare e animare 

traiettorie) utilizzando il campo di forze AMBER, formulato specificamente per descrivere proteine e acidi 

nucleici. 

Per calcolare una traiettoria con Chimera, procuriamoci una proteina di piccole dimensioni (i calcoli di 

Dinamica molecolare sono piuttosto impegnativi per l’hardware), ad esempio la Crambina, una proteina 

presente nel Cavolo abissino. La solita ricerca in Rete inserendo la voce “Crambina PDB” ci restituisce un 

codice PDB = 1CRN.  Lo inseriamo nella ricerca “Fetch” di Chimera. Il risultato è il seguente (dopo aver 

colorato la struttura secondaria con “Tools > Depiction > Color Secondary Structure”) 

 

Clicchiamo su “Tools > MD/Ensemble Analysis > Molecolar Dynamics Simulation”.  Per effettuare una 

simulazione di Dinamica Molecolare corretta andrebbero settati tutta una serie di parametri presenti nelle 

schede “Prep Structure” “Solvation” “Constrains” e “Run Parameters”. Qui noi accettiamo tutti i valori di 

default e clicchiamo direttamente sul pulsante “Run” presente sull’ultima scheda “Run Parameters”.  



 

Si apriranno altre finestre alle quali daremo l’OK. La simulazione può impiegare parecchi minuti. Alla fine, se 

tutto va bene, comparirà la finestra “MD Movie: Dynamics Trajectory” 

  

Spostando con il mouse il cursore triangolare si vedrà la molecola contorcersi percorrendo la sua 

traiettoria. Cliccando sul menu “File > Record movie…” si aprirà una finestra simile a quella già vista per la 

registrazione delle animazioni. Sarà sufficiente inserire il nome del file mp4 che vogliamo produrre e 

cliccare su “Record”. Si noti che essendo i frames di una traiettoria dell’ordine delle migliaia Chimera 

propone di registrarne (in “step size”) 1 ogni 4 (la proposta è diversa a seconda del numero di frames 

ottenuti). 



 

La creazione del videoclip può essere fatta sia con la proteina in rappresentazione “Ribbon”, sia con la 

proteina in altra rappresentazione. Qui di seguito i due videoclip ottenuti in rappresentazione “Ribbon” 

(211 kB) e in rappresentazione “Stick” (423 kB). 

crambina_ribbon.mp4   e  crambina_stick.mp4 

Ritorniamo ora alla finestra “MD Movie: Dynamics Trajectory” e clicchiamo sul menu “File > save PDB..”. Si 

aprirà una finestra che ci permetterà di salvare la traiettoria sotto forma di un file PDB multiplo, contenente 

in sequenza tutte le conformazioni della molecola che si succedono nella traiettoria. Sarà sufficiente 

inserire il nome del file da salvare, attivare l’opzione “save all frames” e cliccare su “Save. 

 

Il file PDB multiplo così salvato può essere riaperto da Chimera attraverso il menù “Tools > MD/Ensemble 

Analysis > MD Movie”.   Nella finestra “Get Ensemble info” che si aprirà selezioniamo PDB in “Trajectory 



format” tra i diversi tipi di traiettorie che Chimera può leggere e andiamo poi a caricare il file cliccando su 

“Browse”  

 

Ci ritroveremo con la proteina caricata e la finestra “MD Movie: PDB trajectory” aperta e pronta a generare 

un videoclip dal menù “File > Record movie…”  come abbiamo già visto. 

 

Il file PDB multiplo così salvato può essere riaperto e trasformato in un videoclip anche da JMol, VMD e 

Sirius (come vedremo più avanti). VMD può inoltre salvare la traiettoria in altri formati (DCD, CRD, TRR, 

XYZ), rendendola in tal modo disponibile per altri programmi. 

***** 

Chimera è in grado di caricare e trasformare in videoclip anche traiettorie in formato DCD, come ad 

esempio quelle prodotte da VMD-NAMD. Vedremo tra poco come utilizzare VMD per eseguire una 

simulazione di Dinamica molecolare che ci consentirà di generare i file DCD e PSF che usiamo qui con 

Chimera. 

Apriamo Chimera e clicchiamo su menù "Tools > MD/Ensemble > MD Movie" e alla voce “Trajectory 

Format” selezioniamo "NAMD (PSF/DCD)” 



 

Per la voce voce “PSF” clicchiamo su “Browse” e carichiamo il file “1pgb_autopsf.psf” generato da 

VMD/NAMD. Per la voce “DCD” clicchiamo su “Add..” e carichiamo il file “1pgb_autopsf.dcd” e clicchiamo 

infine su “OK”.  

Ci ritroveremo con la proteina caricata e la finestra “MD Movie: PDB trajectory” aperta e pronta a generare 

un videoclip dal menù “File > Record movie…”  come abbiamo già visto. 

 

Il risultato è il seguente 

1pgb_chimera.mp4 (233 kB) 

 

 

Torna all’indice 

Jmol 

In Jmol 14.30.2 apriamo il file PDB multiplo (salvato con Chimera) utilizzando il menù “File > Apri”. Nella 

finestra che si apre mettiamo un segno di spunta sulla voce “Accoda modelli” e apriamo il PDB multiplo. 



 

Jmol non produce videoclip, ma i singoli frames. Creiamo all’interno della cartella di installazione di Jmol 

una cartella “frames” dove verranno memorizzati i frames della traiettoria generati da Jmol.  

Ridimensioniamo la finestra di visualizzazione regolandola su valori pari di larghezza e altezza (per evitare 

problemi con il codec mp4).  

Centriamo la molecola nella finestra di visualizzazione tramite “SHIFT+ doppio clic sinistro”. Per eventuali 

altri spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Rotazione in z (Shift + clic sinistro + trascina destra/sinistra), 

- Zoom (Shift + clic sinistro + trascina alto/basso) 

- Traslazione (ctrl+ clic destro + trascina)  

Definiamo l’aspetto della molecola (ad esempio “ball&stick”) con un clic destro all’interno della finestra di 

visualizzazione e clic su “Stile > Schema > Sferette e Bastoni”. 

Se la Console di linea di comando non è già aperta, apriamola con un clic destro all’interno della finestra di 

visualizzazione e clic su “Console”. 

All’interno della Console scriviamo la seguente stringa, seguita dal tasto “Invio”. 

write frames {*} 350 280 "frames/all.png" 



 
Nella cartella “frames” verranno scritti I fotogrammi come file all0001.png,  all0002.png, all0003.png etc. 

350 e 250 sono le dimensioni (larghezza x altezza) che abbiamo dato alla finestra di visualizzazione e che 

avranno i fotogrammi (ma possiamo dare qualsiasi valore). 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto.  

È possibile  ridefinire l’aspetto della molecola (ad esempio “Cartoon”) con un clic destro all’interno della 

finestra di visualizzazione e clic su “Stile > Schema > Fumetto” e rieseguire tutte le operazioni.  

Il risultato è il seguente 

Crambina_Jmol_B&S.mp4  (490kB)   e   Crambina_Jmol_fumetto.mp4 (238 kB) 

Volendo è possibile generare anche fotogrammi in formato GIF con il comando 

write frames {*} 350 280 "frames/all.gif" 

e poi caricarli in PhotoScape per trasformarli in una GIF animata. Tuttavia le traiettorie presentano in 

genere un numero di frames così elevato che la GIF animata avrebbe dimensioni proibitive (decine di MB).  

***** 

Jmol è in grado di caricare e trasformare in videoclip anche traiettorie in formato DCD, come ad esempio 

quelle prodotte da VMD. Vedremo tra poco come utilizzare VMD per eseguire una simulazione di Dinamica 

molecolare che ci consentirà di generare i file DCD e PDB che usiamo qui con Jmol. 

Apriamo Jmol  e, come al solito, creiamo all’interno della cartella di installazione di Jmol una cartella 

“frames” dove verranno memorizzati i frames della traiettoria generati da Jmol.  Se la Console di linea di 

comando non è già aperta, apriamola con un clic destro all’interno della finestra di visualizzazione e clic su 

“Console”. 

Supponendo che i file PDB e DCD siano nella cartella “C:/PDB” all’interno della Console scriviamo la 

seguente stringa, seguita dal tasto “Invio”. 

load trajectory "C:/PDB/1pgb_autopsf.pdb" coord "C:/PDB/1PGB_autopsf.dcd" 

Definiamo l’aspetto della molecola e poi, sempre da Console, scriviamo 



write frames {*} 350 246 "frames/all.png" 

dove 350 e 246 sono le dimensioni (larghezza x altezza) che avranno i frames (ma possiamo dare qualsiasi 

valore). 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto. Il risultato è il seguente 

1pgb_Jmol.mp4 (220kB) 

***** 

Allo stesso modo Jmol è in grado di caricare e trasformare in videoclip anche traiettorie in formato ARC, 

come ad esempio quelle prodotte, come vedremo in seguito, da Force Field Explorer tramite il programma 

di dinamica molecolare Tinker. 

***** 

Jmol è in grado di caricare e trasformare in videoclip anche traiettorie di ottimizzazione in formato XYZ 

come quelle generate, come vedremo in seguito, da MoCalc (tramite i programmi di Dinamica molecolare 

Mopac, Firefly e NWChem).  

***** 

Jmol è in grado di caricare e trasformare in videoclip anche vibrazioni come ad esempio quelle generate da 

IQmol (tramite il programma di Dinamica molecolare Q-Chem). Più avanti vedremo come generare con 

IQmol il file OUT contenente le vibrazioni del Mercaptopropanone che usiamo qui con Jmol. 

Avviamo Jmol  e apriamo il file OUT utilizzando il menù “File > Apri”. Creiamo all’interno della cartella di 

installazione di Jmol una cartella “frames” dove verranno memorizzati i frames generati da Jmol. All’interno 

della “Console” appaiono le 28 frequenze (28 models).  

 

Clicchiamo sul menu “Strumenti > Vibra > Inizia vibrazione”. Clicchiamo quindi sui tasti con le frecce blu in 

alto a destra della finestra di visualizzazione per passare da una vibrazione all’altra (il numero d’ordine della 

vibrazione e la sua frequenza sono mostrati sia nella parte alta che nella parte bassa della finestra di 

visualizzazione). Quando decidiamo di registrare su frames la vibrazione che stiamo visualizzando, 

scriviamo all’interno della Console la seguente stringa, seguita dal tasto “Invio”. 

write vibration   1   470 290 frames/all.png 



Se vogliamo registrare i frames relativi a due cicli completi di vibrazione il comando sarà 

write vibration   2   470 290 frames/all.png 

Tuttavia i frames di un ciclo dovrebbero essere sufficienti se mandiamo poi in loop il videoclip. 

470 e 290 sono le dimensioni (larghezza x altezza) che avranno i fotogrammi (ma possiamo dare qualsiasi 

valore). Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il 

videoclip mp4 come abbiamo già visto. Il risultato è il seguente 

 

 Mercaptopropanone_ freq_Jmol.mp4 (11 kB) 

***** 

Jmol è in grado di caricare e trasformare in videoclip anche le vibrazioni generate da MoCalc tramite Firefly 

o NWChem. Più avanti vedremo come generare con Firefly il file GAM (o con NWCHem il file NWO)  

contenente le vibrazioni del’Etanolo che usiamo qui con Jmol. Il procedimento è uguale a quello che 

abbiamo appena visto e il risultato è il seguente 

Etanolo_Firefly(Jmol_freq).mp4 (7 kB) 

Il file GAM contiene anche 39 Orbitali molecolari nel primo dei 27 modelli (mentre il file NWO contiene 20 

orbitali molecolari nel primo di 26 modelli) . Per visualizzarne uno selezioniamo il primo modello con un 

“clic destro” sulla molecola e dal menu a comparsa scegliamo la voce “modello…” e poi  “Superfici > 

Orbitale molecolare > n orbitale”. 

Per sostituire la retinatura con una superficie solida, scriviamo il seguente comando in Console 

mo fill nomesh 

per rendere la superficie trasparente scriviamo il seguente comando in Console 

mo translucent 

Una volta visualizzato l’orbitale possiamo utilizzare lo script “movie.jmol” (che vedremo tra poco) per 

ottenere una rotazione della struttura. Una volta generati i frames sarà sufficiente caricare il primo frame 

con Virtualdub2 per generare il videoclip mp4 come abbiamo già visto. Il risultato per il 12° orbitale è il 

seguente 

 

Etanolo_Firefly(Jmol_orb).mp4 (25 kB) 

***** 

Con Jmol possiamo creare frames per videoclip anche usando script. Carichiamo una molecola, ad esempio 

il file 1CRN.pdb della Crambina. Creiamo un file di testo e scriviamo all’interno la seguente serie di comandi 

for (var i=0; i<36; i=i+1) 
  write image 320 240 @{"frames/movie" + ("0000" + i)[-3][0] + ".png"} 
  rotate axisangle {1 1 0} 10 
end for 

 



Lo script salva nella cartella “frames” (che deve essere stata creata all’interno della cartella di installazione 

di Jmol) 36 frames in formato PNG delle dimensioni di 320 x 240 pixel. È possibile cambiare, la cartella di 

destinazione, le dimensioni dei frames e il loro formato (è sufficiente sostituire “.PNG” con “.GIF” o “.JPG”). 

E’ inoltre possibile cambiare il tipo di rotazione, modificando il comando “rotate axisangle {1 1 0} 10” 

Per avere una rotazione intorno all’asse X 

rotate axisangle {1 0 0} 10 

Per avere una rotazione intorno all’asse Y 

rotate axisangle {0 1 0} 10 

Per avere una rotazione intorno all’asse Z 

rotate axisangle {0 0 1} 10 

Per avere una rotazione intorno agli assi X e Y 

rotate axisangle {1 1 0} 10 

Una volta creato il file di testo contenente lo script rinominiamolo “movie.jmol”, salviamolo nella cartella di 

Jmol  e nella Console scriviamo 

script "movie.jmol" 

e diamo “Invio”. Il risultato, per una rotazione attorno a X e Y, è il seguente 

Crambina_Jmol_rot.mp4  (113kB)  

***** 

Jmol è in grado di caricare e trasformare in videoclip anche vibrazioni come quelle generate da MoCalc 

(tramite il programma di Dinamica molecolare Mopac). Più avanti vedremo come generare con MoCalc il 

file MNO contenente le vibrazioni e il file MGF contenente gli orbitali molecolari dell’Urea che usiamo qui 

con Jmol. 

Apriamo Jmol e carichiamo il file MNO (che contiene le vibrazioni) utilizzando il menù “File > Apri”. 

Creiamo all’interno della cartella di installazione di Jmol una cartella “frames” dove verranno memorizzati i 

frames generati da Jmol. All’interno della “Console” appaiono le 22 frequenze (22 models) che sono state 

calcolate.  

Clicchiamo sul menu “Strumenti > Vibra > Inizia vibrazione”. Clicchiamo quindi sui tasti con le frecce blu in 

alto a destra della finestra di visualizzazione per passare da una vibrazione all’altra. Quando decidiamo di 

registrare su frames la vibrazione che stiamo visualizzando, scriviamo all’interno della Console la seguente 

stringa, seguita dal tasto “Invio”. 

write vibration   1   400 246 frames/all.png 

400 e 246 sono le dimensioni (larghezza x altezza) che avranno i fotogrammi (ma possiamo dare qualsiasi 

valore). Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il 

videoclip mp4 come abbiamo già visto. Il risultato per la 12ma frequenza è il seguente 

 

Urea_ freq_Jmol.mp4 (5 kB) 

Sempre con Jmol carichiamo ora il file MGF (che contiene gli orbitali). La console ci informa che sono stati 

caricati 16 orbitali molecolari. Per visualizzare uno dei 16 orbitali, facciamo un “clic destro” sulla molecola e 

dal menu a comparsa scegliamo “Superfici > Orbitale molecolare > n orbitale”. 



Una volta visualizzato l’orbitale possiamo utilizzare lo script “movie.jmol” che abbiamo già visto in 

precedenza per ottenere una rotazione della struttura. Una volta generati i frames sarà sufficiente caricare 

il primo frame con Virtualdub2 per generare il videoclip mp4 come abbiamo già visto. Il risultato per il 1° 

orbitale è il seguente 

 

Urea_ orbit_Jmol.mp4 (98 kB) 

 

Torna all’indice 

VMD 

Vediamo ora come VMD 1.9.3 può trasformare in un videoclip il file PDB multiplo generato da Chimera. 

Apriamo VMD e carichiamo il file PDB-traiettoria da menu “File > New molecule…” 

Definiamo l’aspetto della molecola cliccando da menù  “Graphics > Representations”. Nella finestra che si 

aprirà selezioniamo “Coloring Method > Secondary Structure” e “Drawing Method > New Cartoon” 

 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (tasto R da tastiera + Clic sinistro + trascina) 

- Rotazione in z (tasto R da tastiera + Clic destro + trascina), 

- Zoom (tasto T da tastiera + Clic destro + trascina destra/sinistra) 

- Traslazione (tasto T da tastiera + Clic sinistro + trascina)  

Per ridimensionare la finestra in modo preciso, apriamo la console cliccando sul menu “Extensions > Tk 

Console..” e inseriamo (ad esempio) il comando 

display resize 350 280 



 

Ora clicchiamo il menu "Extensions > Visualization > Movie maker". Si aprirà la finestra “VMD Movie 

Generator”. Qui impostiamo la cartella di lavoro (“Set working directory”) dove VMC scriverà i frames in 

formato BMP dell’animazione e assegniamo un nome (“Name of movie”) al videoclip che verrà generato. 

 

 

Poi clicchiamo il menu “Renderer” e selezioniamo il motore del rendering (PovRay dà i migliori risultati, ma 

è piuttosto laborioso, un buon compromesso è “Internal Tachyon”).  In “Movie Setting” mettiamo un 

segno di spunta su “Trajectory” e  deselezioniamo “Delete image files” in modo che al termine della 

creazione del videoclip i singoli frames non vengano cancellati e si possa usarli con VirtualDub2. 

 



Dal menù  “Format” è possibile scegliere il framerate e il formato (AVI o MPEG). Tuttavia VMD si appoggia 

per la creazione del videoclip ad un programma esterno (VideoMACH) che va installato, non sempre 

funziona a dovere e, non essendo freeware, mette il suo logo sul video. Meglio dunque tenere i frames e 

convertirli con Virtualdub2. 

A questo punto clicchiamo su “Make Movie”. Al termine della creazione dei frames VMD ci avviserà che 

non trova VideoMACH e ci chiederà se vogliamo dirgli dove è installato. Gli diremo di NO. 

Di seguito i videoclip prodotti con Virtualdub2 a partire dai frame con rappresentazione “New Cartoon” 

(236 kB) e “Licorice” (488 kB) 

Crambina_VMD_NewCartoon.mp4  e Crambina_VMD_Licorice.mp4 

***** 

VMD può caricare anche traiettorie in formato CRD (come quelle prodotte prodotte da Molby) e 

trasformarla in un videoclip. Come vedremo in seguito Molby genera (a partire da un file PDB)  un file PSF e 

un file CRD.  Apriamo dunque VMD e, da menu “File > New molecule…”, carichiamo il file PSF (o il file PDB) 

salvato da Molby. Poi carichiamo la traiettoria CRD sempre con lo stesso menu. 

 

Definiamo l’aspetto della molecola cliccando da menù  “Graphics > Representations”. Nella finestra che si 

aprirà selezioniamo “Coloring Method > Type” e “Drawing Method > CPK” 

 

Ora clicchiamo il menu "Extensions > Visualization > Movie maker". Si aprirà la finestra “VMD Movie 

Generator”. Qui seguiamo le istruzioni che abbiamo già visto per creare un’animazione con VMD a partire 

da un file traiettoria in formato PDB multiplo.  

Di seguito il videoclip prodotto con Virtualdub2 a partire dai frames con rappresentazione “Ball&stick”  

 2-amminobutanoico_VMD.mp4 (234 kB) 



***** 

Allo stesso modo VMD è in grado di caricare e trasformare in videoclip anche traiettorie di ottimizzazione in 

formato XYZ come quelle generate, come vedremo in seguito, da MoCalc (tramite i programmi di Dinamica 

molecolare Mopac, Firefly e NWChem).  Il videoclip ottenuto è visualizzabile nella sezione dedicata a 

Mocalc. 

***** 

 

VMD è in grado di eseguire semplici simulazioni di dinamica molecolare e di produrre traiettorie in formato 

DCD trasformabili in animazioni sia da VMD che da BallView e Sirius. 

VMD non possiede un editor molecolare, ma può solo caricare file molecolari già esistenti. Ci procuriamo 

dal WEB (ad esempio con la funzione Fetch di Chimera) la proteina con codice PDB = 1PGB (si tratta del 

dominio di legame della Proteina G dello streptococco) e la carichiamo in VMD da menu “File > New 

molecule…”. VMD in realtà non esegue simulazioni di dinamica molecolare ma si appoggia al programma 

NAMD di cui costituisce una sorta di GUI (Graphical User Interface). NAMD e tutti i suoi file devono trovarsi 

all’interno della cartella di installazione di VMD. 

Per eseguire sul file 1pgb.pdb la simulazione di dinamica molecolare è necessario creare un file PSF per 

NAMD. Un file PSF (protein structure file) contiene tutte le informazioni specifiche sulla molecola 

necessarie per applicare un particolare campo di forza a un sistema molecolare.  

Clicchiamo sul menù "Extensions > Modeling > automatic PSF Builder". Nella finestra che si aprirà 

aggiungiamo alla lista di “Topology Files” (cliccando su “Add”)  il file "par_all36_prot.prm" che si trova nella 

cartella "plugins/noarch/tcl/readcharmpar1.3/" di VMD. Una volta aggiunto alla lista, selezioniamolo e 

clicchiamo su "Load input files". 

 

Ora clicchiamo in sequenza su "Guess and split chains..", su "Create chains" e infine su "Apply patches..". 

Ora clicchiamo sul menù "Extensions > Simulation > NAMD Grahical interface" e aggiungiamo 

nuovamente, cliccando su “Add” come abbiamo fatto in precedenza, il file "par_all36_prot.prm" alla lista 

"Parameters files". 

Selezioniamo la voce "Molecolar dynamics" e clicchiamo su "Run NAMD" 

 



 

Se la simulazione va a buon fine la voce “Status: Running” in fondo alla finestra “NAMDgui” diventerà 

“Status: ready” e all’interno della cartella “VMD” troveremo il file “1pgb_autopsf.pdb”, il file 

“1pgb_autopsf.psf”  e  il file traiettoria “1pgb_autopsf.dcd” che utilizzeremo per le animazioni. 

In VMD carichiamo per primo il file traiettoria “1pgb_autopsf.dcd” e poi il file “1pgb_autopsf.pdb” entrambi 

tramite menu “File > New molecule…”. Trascinando il cursore che si trova alla base della finestra principale 

(“VMD Main”) sarà possibile visualizzare la molecola in movimento lungo la sua traiettoria. 

 

A questo punto clicchiamo sul menu  "Extensions > Visualization > Movie maker" e generiamo i frames da 

convertire in un videoclip, con le modalità che abbiamo già visto. Ricordiamoci in “Movie Setting” di 

mettere un segno di spunta su “Trajectory” e  di deselezionare “Delete image files” in modo che al termine 

della creazione del videoclip i singoli frames non vengano cancellati e si possa usarli con VirtualDub2.  

Ed ecco il risultato  

1pgb_VMD.mp4 (280 kB) 



***** 

Un’altra interessante caratteristica di VMD è quella di poter convertire una traiettoria da un formato 

all’altro. In particolare, una volta caricata una qualsiasi traiettoria, può salvarla (tramite menu “File > Save 

Coordinates..”) nei formati PDB multiplo, DCD, CRD, TRR e XYZ multiplo. 

Le traiettorie in formato XYZ generate tramite conversione da VMD non sempre sono corrette e compatibili 

con altri programmi. Per essere certi di ottenere una traiettoria XYZ corretta è necessario seguire una via 

un po’ tortuosa. Usiamo VMD per salvare la traiettoria in formato DCD. Carichiamo il file DCD con Chimera 

tramite menu “Tools > MD/Ensemble Analysis > MD Movie”.   Nella finestra “Get Ensemble info” che si 

aprirà selezioniamo CHARMM  in “Trajectory format” e andiamo poi a caricare i file DCD e PSF cliccando su 

“Browse” (Nel caso non si disponga del file PSF può essere creato usando Molby, come vedremo più 

avanti).  Dalla finestra “MD Movie” di Chimera usiamo il menu “File > Save PDB…” per salvare la traiettoria 

in formato PDB multiplo, avendo l’accortezza di selezionare la voce “Save all frames”. Ora carichiamo il PDB 

multiplo con VMD e salviamolo in formato XYZ multiplo tramite menu “File > Save Coordinates..” 

 

***** 

VMD può generare anche semplici videoclip (rotazioni e rock&roll) su qualsiasi molecola caricata.  

Carichiamo ad esempio il file 1CRN.pdb della Crambina e clicchiamo il menu "Extensions > Visualization > 

Movie maker". 

impostiamo la cartella di lavoro (“Set working directory”) dove VMC scriverà i frames. In “Movie Setting” 

mettiamo un segno di spunta su “Rock&Roll” (o su “Rotation about y axis”) e  deselezioniamo “Delete 

image files” in modo che al termine della creazione del videoclip i singoli frames non vengano cancellati e si 

possa usarli con VirtualDub2. Dal menù  “Format > Change compression settings..” impostiamo il 

framerate a 25 fps. Sulla voce “Movie duration (seconds)” impostiamo 4 secondi (teniamo presente che 

con un framerate = 25 fps e una durata di 4 secondi vengono generati 100 frames)  e clicchiamo infine su 

“Make Movie”. Di seguito il videoclip prodotto con Virtualdub2 a partire dai frames con movimento 

Rock&roll. 

Crambina_VMD_rock.mp4 (208 kB) 

Torna all’indice 

Sirius 

Vediamo ora come Sirius 1.2 può trasformare in un videoclip il file PDB multiplo generato da Chimera. 

Apriamo Sirius e clicchiamo sul menu “Tools > Molecular Dynamics Panel. Nella finestra che si apre 

carichiamo il file PDB-traiettoria da menu “File > Load concatenated file…” 



 

Definiamo l’aspetto della molecola cliccando sul menù  “Appearance > Structure rendering..”. Nella 

finestra che si aprirà selezioniamo la molecola nel menu a discesa in basso a sinistra, selezioniamo il 

“Rendering style” (ad esempio “Ball and stick”) e diamo l’OK. 

 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Rotazione in z (Shift + Clic sinistro + trascina), 

- Zoom (rotella centrale) 

- Traslazione (Clic destro + trascina)  

Andiamo alla finestra “Molecular Dynamics Panel” e clicchiamo sul menu “Export trajectory as video..”. 

Nella finestra che si apre possiamo decidere se utilizzare tutti i frames o solo una parte. Settiamo il 

framerate a 25, diamo il nome al videoclip che verrà salvato in formato Apple QuickTime MOV. 

 



 

Il file mov generato è piuttosto pesante e può essere ricodificato in mp4 usando diversi software freeware. 

Uno dei migliori e più efficienti è XMediaRecode, ma anche VirtualDub2 va bene. 

Dallo stesso menù di “Molecular Dynamics Panel” è possibile scegliere la voce “Save trajectory as a set of 

POV-Ray files…”. Verrà generato un file con estensione POV per ogni frames. I file POV dovranno poi essere 

caricati e convertiti in frames BMP da POV-Ray. I frames BMP potranno infine essere convertiti in un 

videoclip con VirtualDub2. 

POV-Ray è un programma di Raytracing freeware. È in grado di convertire in batch molti file POV uno di 

seguito all’altro. È sufficiente cliccare sul menu “Render > File Queue”, caricare tutti i file POV e dare ok. 

Cambiamo ora l’aspetto della molecola. Dobbiamo nascondere la visualizzazione in “ball&stick” e attivare 

quella in “cartoon”.  

Per nascondere la struttura atomica della molecola clicchiamo sul menù  “Appearance > Show/Hide atomic 

structure..”. Nella finestra che si aprirà selezioniamo la molecola nel menu a discesa in basso a sinistra, 

attiviamo la voce “Hide” e diamo l’OK. 

Per la visualizzazione in modalità “Ribbon” clicchiamo sul menù  “Appearance > Show/Hide ribbon”. Nella 

finestra che si aprirà selezioniamo la molecola nel menu a discesa in basso a sinistra, attiviamo la voce 

“Show” e diamo l’OK. 

 



A questo punto possiamo generare un altro videoclip. 

Di seguito i videoclip prodotti convertendo con XMediaRecode i file MOV in mp4 con rappresentazione 

“Ball&stick” (324 kB) e “Ribbon” (154 kB) e POV-Ray Ribbon (226 kB) ottenuto con  Virtualdub2 a partire dai 

frame generati da POV-Ray  

 Crambina_Sirius_B&S.mp4   e Crambina_Sirius_Ribbon.mp4 

Crambina_Sirius_Povray.mp4 

***** 

Sirius è in grado di caricare e animare anche traiettorie in formato CRD e DCD. Un programma interessante 

capace di produrre rapidamente traiettorie in formato CRD (AMBER) è Molby.   

Proviamo ora ad utilizzare la traiettoria DCD e il file PSF che abbiamo generato con VMD 

Apriamo Sirius e clicchiamo sul menu “Tools > Molecular Dynamics Panel. Nella finestra che si apre 

carichiamo prima il file “1pgb_autopsf.psf” da menu “File > Open Parameter file…” e scegliamo di aprire 

come tipo di file “CHARMM Parameter file” e poi carichiamo la traiettoria DCD “File > Open 

Coordinate/Trajectory file…”. Una volta caricato possiamo salvare, come abbiamo già visto, sia 

l’animazione in formato  MOV, sia i frames come file POV-Ray. 

Di seguito il videoclip prodotto convertendo con VirtualDub2 il file MOV in mp4  

1pgb_Sirius.mp4 

I file traiettoria DCD possono essere letti e trasformati in videoclip anche da JMOL, Pymol, Chimera e 

BALLView. 

Torna all’indice 

Molby 

Molby può caricare molecole in formato PDB (e altri formati poco usati), ma è piuttosto schizzinoso per 

quanto riguarda il PDB. Il più delle volte carica la molecola, ma la visualizza male. Ho notato che in genere 

legge bene i file PDB salvati da BALLView 1.4. Ma BALLView non è efficiente come Chimera nel procurarsi 

molecole e così il metodo più rapido è procurarsi la molecola con Chimera, salvarla in MOL2, caricarla in 

BALLView e salvarla in PDB per Molby. 

Tuttavia Molby ha un editor originale, ma piuttosto efficiente con il quale è possibile costruirsi molecole o 

usare molecole predefinite (grazie al menu “File > Open Predefined”).  

Per disegnare una catena carboniosa si seleziona il pulsante “Bond” e poi “clic sinistro + trascina” si traccia 

il legame tra due atomi di Carbonio. 



 

Se poi clicchiamo nuovamente su uno dei due atomi e trasciniamo otteniamo un altro legame con un terzo 

atomo e così via. 

Un doppio clic sull’atomo di carbonio centrale e lo sostituiamo con un atomo di ossigeno scrivendo il suo 

simbolo chimico nella finestra “Enter formula” che compare. 

 

Attiviamo il pulsante “Selec” e selezioniamo entrambi gli atomi di carbonio terminali tenendo premuto il 

tasto Shift e cliccando prima su uno e poi sull’altro. Poi clicchiamo il menu “Edit > Add Hydrogen > 

Tetrahedral SP3”. 

 



Abbiamo costruito l’etere dimetilico 

 

Se la molecola non è troppo complessa è tuttavia più semplice fare un doppio clic sulla finestra di 

visualizzazione. Comparirà una piccola finestra che richiederà di inserire la formula del composto.  

Ad esempio CH4 (metano)  CH3CH3 (Etano) HCHO (metanale) HCOCH3 (etanale) CH3OH (metanolo)  

CH3OCH3 (etere dimetilico) CH3COCH3 (propanone) CH3COOH (acido acetico).  

Una volta inserita, la molecola può essere modificata in modo abbastanza semplice. Proviamo ad esempio 

ad inserire e modificare il propano CH3CH2CH3 

 

Con il pulsante “Rot” selezionato, il mouse può ruotare la molecola  

Con il pulsante “Trans” selezionato, il mouse può traslare la molecola, 

con il pulsante “Scale” selezionato, il mouse può effettuare uno zoom 

Tutte queste operazioni devono essere eseguite cliccando al di fuori della molecola altrimenti spostiamo i 

suoi atomi e deformiamo la molecola. In questo caso si può tornare indietro cliccando sul menu “Edit > 

Undo”  

La molecola compare completamente selezionata e colorata di rosso. Per deselezionarla basta cliccare sulla 

finestra di sinistra al di fuori dei suoi atomi (selezionati in blu) 

 



Sostituiamo ora uno dei due idrogeni in C2 con un gruppo amminico (-NH2). Selezioniamo l’idrogeno, 

cliccando sul pulsante “Selec” e poi sull’idrogeno. In alternativa è possibile selezionare gli atomi dalla lista a 

sinistra. In questo caso gli atomi di idrogeno legati al Carbonio C2 sono i due che lo seguono nella lista, H4 e 

H5. Per una selezione multipla “Shift + clic sinistro” 

 

Ora un doppio clic sull’idrogeno selezionato che vogliamo sostituire con un gruppo amminico e nella 

finestra che si apre scriviamo “NH2” (Se invece vogliamo sostituire l’atomo selezionato con un altro 

elemento chimico sarà sufficiente scrivere nella finestra “Enter formula” il suo simbolo chimico). 

 

Abbiamo ottenuto una 2-propanammina. Ora, con lo stesso sistema, sostituiamo un idrogeno terminale 

con un gruppo carbossilico COOH. 

 

Abbiamo ottenuto un acido 3-amminobutanoico. 



 

Ora ottimizziamo la geometria della molecola con il comando “MM/MD > minimize…” che trova la 

conformazione di minima energia. Ed ora facciamo partire una simulazione di Dinamica Molecolare 

cliccando su “MM/MD > Molecular Dynamics..”. Nella finestra che comparirà clicchiamo su “Autoguess” e 

nella successiva diamo l’OK ( a meno che non si voglia cambiare il numero dei frames della traiettoria). 

 

Trascinando il cursore sotto la molecola è possibile vedere la molecola contorcersi seguendo la sua 

traiettoria. 

 

Ora salviamo la molecola e la traiettoria. Menu “File>Export..” e salviamo in formato PDB, in formato PSF e 

la traiettoria in formato CRD. 

Ora riapriamo Sirius 1.2 e clicchiamo sul menu “Tools > Molecular Dynamics Panel. Nella finestra che si 

apre carichiamo prima il file PSF da menu “File > Open Parameter file…” e scegliamo di aprire come tipo di 

file “CHARMM Parameter file” e poi carichiamo la traiettoria CRD “File > Open Coordinate/Trajectory 

file…”.  



                    

Una volta caricato possiamo salvare, come abbiamo già visto, sia l’animazione in formato  MOV, sia i frames 

come file POV-Ray. 

Di seguito i videoclip prodotti convertendo con XMediaRecode i file MOV in mp4 con rappresentazione 

“Stick” (200 kB) e POV-Ray Stick (440 kB) ottenuto con  Virtualdub2 a partire dai frame generati da POV-Ray  

Butanoico_Sirius_stick.mp4   e Butanoico_Sirius_POV.mp4 

Torna all’indice 

PyMol 

PyMol è in grado di caricare e trasformare in videoclip traiettorie in formato DCD, come ad esempio quelle 

prodotte da VMD. Apriamo PyMOL 1.3 e, supponendo che  i file PDB e DCD siano nella cartella “C:/PDB”, 

carichiamo prima il file PDB, scrivendo il seguente comando all’interno della Consolle di PyMOL, seguito da 

“Invio” 

load c:/pdb/1pgb_autopsf.pdb 

 

E poi carichiamo il file traiettoria DCD scrivendo il seguente commando, seguito da “Invio” 

load_traj g:/pdb/1pgb_autopsf.dcd 

 

Cliccando sul pulsante “Play” è ora possibile visualizzare i movimenti della molecola che segue la sua 

traiettoria. 



 

Ridimensioniamo la finestra di visualizzazione con valori pari di larghezza e altezza (ad es 320 x 240), in 

modo da evitare problemi con il codec AVC-HEVC per la creazione del videoclip MP4. Possiamo farlo in 

maniera precisa scrivendo il seguente comando in Console. 

viewport 320, 240 

Definiamo l’aspetto della molecola eliminando la visualizzazione “wireframe” e mostrando “cartoon”. Per 

eliminare la visualizzazione corrente clicchiamo su menu H (Hide) in alto a destra nella finestra “PyMOL 

Viewer” e selezioniamo “everything” 

 

Ora clicchiamo sul vicino menu S (Show) e selezioniamo “Cartoon”. 

 



Coloriamo le diverse strutture secondarie cliccando sul menu “C (Color) > by ss > Helix Sheet Loop ” 

 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y o z (Clic sinistro + trascina) 

- Zoom (clic destro + trascina alto/basso) 

- Traslazione (“alt+ clic sinistro + trascina” oppure “tasto centrale + trascina”)  

Ora generiamo i frames cliccando sul menù "File > Save movie as > PNG images". PyMOL ci chiederà di 

dare un nome alla serie di immagini e di indicargli una cartella dove salvarle.   

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto. Il risultato è il seguente 

1pgb_pyMOL.mp4 (246kB) 

***** 

Allo stesso modo PyMol è in grado di caricare e trasformare in videoclip anche traiettorie di ottimizzazione 

in formato XYZ come quelle generate, come vedremo in seguito, da MoCalc (tramite i programmi di 

Dinamica molecolare Mopac, Firefly e NWChem).  Il videoclip ottenuto è visualizzabile nella sezione 

dedicata a MoCalc. 

 

Torna all’indice 

BALLView 

BallView è in grado di caricare e trasformare in videoclip traiettorie in formato DCD, come ad esempio 

quelle che abbiamo prodotto con VMD. Apriamo BALLView 1.4 e carichiamo prima il file PDB 

“1pgb_autopsf.pdb” con il menù “File > Open > Structure" e poi il file DCD “1pgb_autopsf.dcd” con il menù 

"File > Open > Trajectory". 

Definiamo l’aspetto della molecola facendo un “clic destro” sulla voce presente nella finestra 

“Representation” , dal menu a comparsa che si presenta selezioniamo “Modify Model”. 



 

 

Nella finestra “Create a Representation” che si aprirà selezioniamo “Cartoon” in “Model Type” e “By 

secondary structure” in “Coloring Method”. 

 

Se BALLView non visualizza la struttura secondaria possiamo assegnargliela cliccando sul menu “Tools > 

Calculate Secondary Structure” 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Rotazione in z (ctrl + shift + Clic sinistro + trascina) 

- Zoom (shift + clic sinistro + trascina alto/basso) 

- Traslazione (“clic destro + trascina”)  

Il file traiettoria, precedentemente caricato, compare in alto a destra nel riquadro “Dataset”. Eseguiamo un 

clic destro sul file e dal menu a comparsa selezioniamo la voce "Visualize trajectory". 



 

 

Nella finestra “Snapshot Visualisation” che si apre è possibile animare la molecola muovendo il cursore e 

scegliere (in “Start” “End”) il numero di frames da animare. È possibile salvare i frames, come immagini 

PNG (selezionando l’opzione) o anche come file POVray da convertire successivamente in immagini (come 

abbiamo già visto). 

 

Cliccando infine su “Animate” i file PNG vengono salvati nella cartella di installazione di BALLView. Una 

volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

MP4 come abbiamo già visto. Il risultato è il seguente 

1pgb_Ballview.mp4 (329kB) e 1pgb_Ballview_POV.mp4 (426 kB) 

***** 

BallView  possiede anche un editor per costruire molecole ex novo e un’opzione per eseguire simulazioni di 

dinamica molecolare che generano file in formato DCD (caricabili e convertibili in videoclip, da BALLView,  

ma non da JMOL, Sirius, Chimera, VMD e PyMOL che lo leggono male). 

Per costruire una molecola con BALLView è necessario prima inizializzare la molecola, assegnadogli un 

“container” con il comando “Build > Create new molecule”. Poi facciamo un “clic destro” sulla voce 

presente nella finestra “Representation”. Dal menu a comparsa selezioniamo “Modify Model” e 

assegniamo “Ball & stick” in “Model Type” e “By element” in “Coloring Method”. 

Il puntatore del mouse presenta una C poiché è pronto a disegnare un atomo di carbonio. Se vogliamo 

cambiare elemento clicchiamo sull’icona  e scegliamo ad esempio l’ossigeno. Il puntatore ora è 

accompagnato da una O e se clicchiamo sulla finestra di visualizzazione compare un atomo di Ossigeno. 



Clicchiamo sull’icona  e verranno aggiunti all’Ossigeno gli idrogeni necessari. Abbiamo creato una 

molecola d’acqua. Se facciamo la stessa cosa con l’Azoto, si formerà una molecola di Ammoniaca NH3, con il 

carbonio una molecola di Metano CH4. 

Ora proviamo a costruire una molecola organica più complessa. Disegniamo una catena di 4 atomi di 

Carbonio. Clicchiamo con il mouse e trasciniamo per formare il primo legame tra due atomi. Poi ci 

spostiamo fuori della struttura, clicchiamo per formare un nuovo atomo di C e trasciniamo fino a 

congiungerlo con un legame ad uno dei due atomi precedentemente inseriti. 

 

Ripetiamo 

 

Ora cambiamo elemento e scegliamo l’Ossigeno cliccando sull’icona  e colleghiamo un atomo di Ossigeno 

in C2 

 

Cambiamo ancora elemento, scegliamo l’Azoto e cambiamo il Carbonio C4 in Azoto con un doppio clic sul 

C4. Un doppio clic sul legame C-O e trasformiamo il legame semplice in un legame doppio C=O (se facciamo 

un altro doppio clic il legame diventa triplo e poi ancora semplice e via di seguito). 

Clicchiamo sull’icona  e verranno aggiunti tutti gli atomi di Idrogeno necessari. Abbiamo costruito 

l’Amminopropanone. 

 

Clicchiamo sull’icona  per una ottimizzazione veloce della geometria della molecola (viene ricercato il 

minimo di Energia utilizzando il campo di forze MMFF94). Ora centriamo la molecola nella finestra di 

visualizzazione, cliccando sul menu “Display > Viewpoint > Focus Camera”. Per salvare la molecola 

clicchiamo su menu “File > Save Structure”. 

***** 

Ora eseguiamo una simulazione di Dinamica Molecolare su una molecola di Etanolo che ci procuriamo 

utilizzando l’opzione SMILES di BallView. Una veloce ricerca sul WEB inserendo la voce “Etanolo SMILES” ci 



fornisce la stringa SMILES  CCO.  Clicchiamo sul menu “Build > Build from SMILES”, inseriamo la stringa 

SMILES e clicchiamo su “Generate” e poi su “Add”. 

 

Clicchiamo sull’icona  per una ottimizzazione veloce della geometria. Eseguiamo la simulazione di 

dinamica molecolare  cliccando sul menu “Molecular Mechanics > Molecular Dynamics”. Nella finestra che 

si apre scegliamo come campo di forze MMFF94 (Amber e CHARMM sono specifici per proteine e acidi 

nucleici). Clicchiamo su “Browse” e diamo un nome al file traiettoria DCD che verrà generato. Facciamo 

partire la simulazione cliccando su “Simulate”. 

 

Al termine della simulazione Il file traiettoria compare in alto a destra nel riquadro “Dataset”. Eseguiamo 

un clic destro sul file e dal menu a comparsa selezioniamo la voce "Visualize trajectory". Nella finestra 

“Snapshot Visualisation” che si apre è possibile salvare i frames, come immagini PNG (selezionando 

l’opzione) o anche come file POVray da convertire successivamente in immagini (come abbiamo già visto). 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

MP4 come abbiamo già visto. Il risultato è il seguente 

Etanolo_Ballview.mp4 (103kB) 

***** 

BallView può in realtà generare animazioni su qualsiasi molecola caricata, registrando le azioni che l’utente 

esegue sulla molecola.  Dopo aver scaricato dal sito “www.rcsb.org” il file “7znf.pdb” (che contiene un 

motivo proteico a “dito di Zinco”) lo apriamo in BallView. Definiamo l’aspetto della molecola facendo un 

“clic destro” sulla voce presente nella finestra “Representation” e dal menu a comparsa che si presenta 



selezioniamo “Modify Model”. Nella finestra “Create a Representation” che si aprirà selezioniamo 

“Cartoon” in “Model Type” e “By secondary structure” in “Coloring Method”. 

Ora visualizziamo l’atomo di Zinco. Nella finestra “Structures” clicchiamo sulla molecola (7znf) in modo da 

aprire i sottomenu e visualizzare le sue componenti. Un clic destro sull’atomo di Zinco e dal menu che 

compare scegliamo “Create Representation > VDW > by element”. 

 

Ora visualizziamo i 4 residui aminoacidici (2 Istidine  e 2 Cisteine) che formano legami dativi con l’atomo di 

Zinco. Sempre nella finestra “Structures” clicchiamo sulla prima catena A in modo da aprire i sottomenu e 

visualizzare tutti gli aminoacidi di cui è composta la catena proteica. Un clic destro su “Cys 5” (La cisteina in 

quinta posizione) e dal menu che compare scegliamo “Create Representation > stick > by element”. 

Ripetiamo l’operazione per la Cisteina in posizione 8 (“Cys 8”) e poi per le due istidine in posizioni 21 e 26 

(“His 21” e “His 26”) 

 

Ora predisponiamo la registrazione. Clicchiamo sul menu “Display” e selezioniamo la voce “Export PNG” 

(e/o “Export POV” se vogliamo che oltre ai frames PNG siano generati file “POV”) e “Record”. 

 



 

A questo punto il programma non genera i frames, ma memorizza i movimenti a cui l’utente sottopone la 

molecola (rotazioni, zoom etc). Una volta che abbiamo terminato di muovere la molecola (io ho eseguito 

uno zoom verso l’atomo di Zinco ed una piccola rotazione per centrare la struttura) possiamo generare i 

frames, cliccando su “Display > Animation > Start”. Se invece non siamo soddisfatti dei movimenti eseguiti 

è necessario azzerare la memoria cliccando su “Display > Animation > Clear”. 

Una volta generati i frames è necessario cancellare il primo frame (forse per un bug è sempre sbagliato) e 

poi caricare il secondo frame con Virtualdub2 per generare il videoclip MP4 come abbiamo già visto. Il 

risultato è il seguente 

ZincFinger_Ballview.mp4 (70kB) 

***** 

Le operazioni di registrazione manuale dei movimenti con BallView possono risultare macchinose e poco 

precise. È quindi più semplice e conveniente utilizzare degli script che automatizzano il procedimento. 

Per ottenere ad esempio una rotazione di 360° di una generica molecola “molecola.pdb” che si trova nella 

cartella “C:/pdb” è sufficiente creare un file di testo con il seguente script Python, rinominarlo ad esempio 

“rotazione.py” ed eseguirlo all’interno del “Python Interpreter” di BallView 

clearAll() 
 
openFile(Path().find("C:/pdb/molecola.pdb")) 
 
angle_step = 6 
  
s = getScene() 
m = getMainControl() 
camera = Camera(s.getStage().getCamera()) 
 
getDisplayProperties().selectModel(MODEL_BALL_AND_STICK) 
getDisplayProperties().selectColoringMethod(COLORING_ELEMENT) 
getDisplayProperties().setDrawingPrecision(DRAWING_PRECISION_HIGH) 
 
def my_task(): 
 m.processEvents(1000) 
 s.exportPNG() 



 
for i in range(0, 732 / angle_step): 
 s.rotate(angle_step, 0) 
 my_task() 
 
s.setCamera(camera) 

 

Se non è già aperto, apriamo il ” Python Interpreter”  cliccando sul menu “Windows > Python Interpreter”. 

Clicchiamo poi sulla scheda “Scripting Mode” e qui clicchiamo su “Clear” e poi su “Load” per caricare lo 

script “rotazione.py” ed infine su “Run”.  I frames PNG vengono generati all’interno della cartella di 

installazione di BallView. Il primo frame va scartato!  

Di seguito il videoclip della rotazione dell’aminoacido Alanina creato caricando il secondo frame con 

Virtualdub2 

Alanina_BALLView.mp4 (100 kB) 

Lo script può essere ovviamente modificato, cambiando il nome del file PDB e della cartella che lo contiene. 

Se vogliamo i file POV al posto ai PNG si sostituisce “s.exportPNG()”   con “s.exportPOVRay()”. Se vogliamo i 

file POV assieme ai PNG si aggiunge “s.exportPOVRay()”. 

Inoltre, per cambiare l’aspetto della molecola, si può sostituire la stringa “MODEL_BALL_AND_STICK” con  

“MODEL _STICK” o con “MODEL _VDW”. 

 

Lo script seguente visualizza invece una proteina in modalità “Cartoon” ed esegue 4 rotazioni di 180 gradi 

alternativamente sugli assi Y e X. 

clearAll() 
 
openFile(Path().find("C:/pdb/proteina.pdb")) 
 
angle_step = 6 
  
s = getScene() 
m = getMainControl() 
camera = Camera(s.getStage().getCamera()) 
 
getDisplayProperties().selectModel(MODEL_CARTOON) 
getDisplayProperties().selectColoringMethod(COLORING_SECONDARY_STRUCTURE) 
getDisplayProperties().setDrawingPrecision(DRAWING_PRECISION_HIGH) 
 
def my_task(): 
 m.processEvents(1000) 
 s.exportPNG() 
 
for i in range(0, 366 / angle_step): 
 s.rotate(angle_step, 0) 
 my_task() 
  
for i in range(0, 366 / angle_step): 
 s.rotate(0, angle_step) 



 my_task() 
 
for i in range(0, 366 / angle_step): 
 s.rotate(angle_step, 0) 
 my_task() 
  
for i in range(0, 366 / angle_step): 
 s.rotate(0, angle_step) 
 my_task() 
 
s.setCamera(camera) 

 

Di seguito il videoclip della rotazione Y-X della proteina Porina (1prn.pdb) creato caricando il secondo frame 

con Virtualdub2 

Porina_BALLView.mp4 (245 kB) 

Nella mia versione di BallView è presente un bug per cui quando si lancia uno script con una modalità di 

visualizzazione della molecola diversa da quella dello script precedente, rimane memorizzata la modalità di 

visualizzazione precedente. È necessario lanciare lo script due volte di seguito per ottenere la modalità 

corretta. 

Come abbiamo visto, BALLView, VMD e Chimera presentano semplici opzioni di Dinamica Molecolare. 

Esistono tuttavia programmi che sono specializzati in questo tipo di calcoli, ma richiedono in genere una 

complessa preparazione dei file di input per poter operare. Tra questi possiamo ricordare i freeware 

GROMACS, TINKER, GAMESS, MOPAC, NWCHEM. Vedremo che esistono alcuni programmi (MOCalc, 

Zephyr, Force Field Explorer, Gabedit, IQMol)  che lavorano come interfacce grafiche (GUI) e semplificano 

notevolmente il lavoro. 

Torna all’indice 

IQmol  (Q-Chem)     

IQmol può importare molecole in formato XYZ, MOL, PDB e SDF. Il formato SDF è interessante poiché è il 

formato con cui è possibile scaricare molecole dal database PubChem. Inoltre IQmol possiede un editor di 

molecole essenziale, ma piuttosto efficiente ed è in grado di comunicare via WEB con server che eseguono 

calcoli di dinamica molecolare usando il software Q-Chem. Q-Chem non è freeware, ma il server con cui 

IQmol si collega esegue gratuitamente calcoli per molecole non troppo grandi. 

Vediamo le funzioni principali del programma accessibili direttamente dalle icone. Quando si clicca un’icona 

e la corrispondente funzione diviene attiva, l’icona si cerchia di rosso. 

 manipolazione molecola tramite mouse.  

- Rotazione =  Clic sinistro + trascina  

- Traslazione = Clic destro + trascina 

- Zoom =  tasto centrale (rotella) 

- Selezione = “Shift + clic sinistro + trascina” o “Shift + clic sinistro multiplo” 



 Costruzione molecola. Il secondo pulsante permette di accedere ad una tabella periodica e di 

scegliere l’elemento attivo.  

- Clic sinistro = Se non esistono atomi crea un atomo dell’elemento attivo. Un clic su un atomo 

esistente lo converte nell’elemento attivo 

- Clic sinistro + trascina = Se il clic parte da un atomo verso l’esterno della molecola si forma un 

legame e un nuovo atomo dell’elemento attivo. Se il clic parte da un atomo verso un altro atomo 

ad esso legato viene aumentato l’ordine di legame (il legame semplice diventa doppio e il doppio 

diventa triplo).  

- Clic destro = eliminazione dell’atomo sotto il puntatore. 

  Inserimento molecole ex novo o gruppi funzionali che sostituiscono con un clic sinistro un atomo di 

una molecola esistente. 

 Aggiunta degli atomi di Idrogeno mancanti ad una molecola in via di costruzione 

 Minimizza l’Energia (ottimizzazione geometria) utilizzando il campo di forza definito con il menu “Build 

> Select Force Field” 

 Il primo pulsante consente di selezionare uno o più atomi con le stesse modalità di “Shift + clic 

sinistro”. Il secondo pulsante cancella gli atomi selezionati. 

 Quando viene cliccato questo pulsante, il programma chiede dove deve salvare i frames PNG 

(trasformabili poi in animazioni) dei cambiamenti conformazionali che avvengono sulla molecola. Ad 

esempio è possibile registrare il processo di ottimizzazione di una molecola e le traiettorie prodotte dalle 

simulazioni di Q-Chem. 

Proviamo ad esempio a costruire il Mercaptopropanone  e a registrare poi la fase di 

ottimizzazione in un’animazione. 

Iniziamo a disegnare con “clic sinistro + trascina” una catena di atomi di carbonio e poi introduciamo il 

doppio legame eseguendo un ulteriore “Clic sinistro + trascina” tra i due atomi interessati. 

                              

Ora dal pulsante che ci permette di accedere alla tabella periodica selezioniamo l’Ossigeno e clicchiamo 

sull’atomo di carbonio coinvolto nel doppio legame per sostituirlo con L’ossigeno 



 

Ora clicchiamo sull’icona  per aggiungere gli Idrogeni (da questo punto in poi le fasi sono registrate nei 

frames e sono visibili nell’animazione che segue). Infine clicchiamo sull’icona  , scegliamo un gruppo 

Tiolo –SH  e clicchiamo su uno degli idrogeni per sostituirlo con il gruppo tiolico. 

 

Il videoclip creato  caricando il primo frame con Virtualdub2 è il seguente 

*********  Mercaptopropanone_IQmol.mp4 (34kB) 

Ora Inviamo la molecola al server Q-Chem per i calcoli di Dinamica Molecolare. Clicchiamo sul menu 

“Calculation > Q-Chem setup”, scegliamo il tipo di calcolo che vogliamo (ad esempio “Frequencies”) e poi 

clicchiamo su “Submit”. 

 

Possiamo seguire l’andamento del calcolo cliccando su “Calculation > Job Monitor”. 



 

Alla fine del calcolo ci viene chiesto di indicare una cartella dove eseguire il download ed il salvataggio dei 

file di risultato. Il file ha estensione OUT e viene automaticamente caricato da IQmol. 

Nella finestra “Model View” apparirà la voce “Frequencies” che contiene le varie frequenze vibrazionali 

calcolate da Q-Chem. Cliccando su ogni frequenza appaiono i vettori forza associati a ciascun atomo. Con 

un doppio clic sulla frequenza la molecola si anima ed esegue la corrispondente vibrazione. 

 

Con un doppio clic sulla voce “Frequencies” si apre la finestra  “Vibrational Frequencies” in cui possiamo 

regolare l’ampiezza (Amplitude) e la velocità (Speed) delle vibrazioni. Se vogliamo  ottenere un videoclip 

delle oscillazioni è bene deselezionare la voce “Loop” in modo che vengano registrati i frames relativi ad un 

solo ciclo 

 



 

Selezioniamo la frequenza desiderata, attiviamo il pulsante  e clicchiamo sul pulsante  per far 

partire l’animazione. È possibile registrare in sequenza più frequenze di oscillazione (verranno registrati i 

frames solo delle oscillazioni senza pause tra una frequenza e l’altra). Di seguito il videoclip di una singola 

frequenza e di più frequenze in serie creati al solito  caricando il primo frame con Virtualdub2  

Mercaptopropanone_ freq_IQmol.mp4 (10 kB)  e  Mercaptopropanone_ freqs_IQmol.mp4 (332 kB) 

Il file OUT generato da Q-Chem e contenente le vibrazioni viene letto e trasformato in frames (e quindi in 

un videoclip) anche da JMol, Gabedit e Avogadro.  

***** 

IQmol è in grado di caricare e trasformare in videoclip anche le vibrazioni generate da MoCalc tramite 

Firefly o NWChem. Più avanti vedremo come generare con Firefly il file GAM (e con NWCHem il file NWO)  

contenente le vibrazioni del’Etanolo che usiamo qui con IQmol. Dopo aver caricato il file GAM (o il file 

NWO) nella finestra “Model View” apparirà la voce “Frequencies”.  Il procedimento per creare i frames di 

una vibrazione è uguale a quello che abbiamo appena visto ed il risultato è il seguente. 

Etanolo_Firefly(IQmol_freq).mp4 (5 kB) 

***** 

IQmol è in grado di caricare e trasformare in videoclip anche traiettorie di ottimizzazione in formato XYZ 

come quelle generate, come vedremo in seguito, da MoCalc (tramite i programmi di Dinamica molecolare 

Mopac, Firefly e NWChem). Il file XYZ contiene la traiettoria di ottimizzazione di una molecola di Etanolo in 

conformazione eclissata, con l’ossidrile che presenta un errato angolo di legame di 180° e l’atomo di 

Idrogeno opposto all’ossidrile con un legame C-H troppo lungo (infatti IQmol non riesce a leggerlo come un 

legame e lascia l’atomo di idrogeno isolato). 

Apriamo IQmol e carichiamo il file XYZ usando il menu “File > Open”. Nella finestra “Model View” apparirà 

la voce “Geometries” che contiene le energie delle diverse strutture molecolari calcolate. Cliccando su ogni 

valore appare la relativa struttura molecolare. 



 

Con un doppio clic sulla voce “Geometries” si apre la corrispondente finestra  in cui appare il percorso di 

ottimizzazione.  

 

Se vogliamo  ottenere un videoclip è bene deselezionare la voce “Loop”. Clicchiamo sul pulsante  e 

indichiamo a IQmol la cartella in cui deve salvare i frames. Clicchiamo sul pulsante  per far partire 

l’animazione e memorizzare contemporaneamente i frames. Di seguito il videoclip creato caricando il primo 

frame con Virtualdub2. 

Etanolo_Firefly(IQmol).mp4 (242 kB) 

 

 

Torna all’indice 

Gabedit 

Gabedit 2.5.0 è una interfaccia grafica (GUI) per molti programmi di Chimica Computazionale che eseguono 

calcoli di Meccanica molecolare, ma è anche in grado di eseguirli autonomamente. Possiede inoltre un 

editor molecolare molto efficiente ed amichevole ed è in grado di generare frames di animazioni, 

traiettorie e vibrazioni, da trasformare in videoclip. 



Apriamo Gabedit e carichiamo il file Mercaptopropanone.out generato da IQmol (tramite il server Q-Chem) 

e contenente le frequenze vibrazionali. Clicchiamo sul pulsante “Display Geometry..” 

 

Nella finestra  “Orbital/Density/Vibration” che si aprirà clicchiamo sul menu “M > Animation >Vibration” 

 

Nella finestra “Vibration” che si aprirà clicchiamo su “File > Read > Read a Q-Chem output file” e 

carichiamo il file Mercaptopropanone.out. 

Ridimensioniamo la finestra “Orbitals/Density/Vibration” che mostra la molecola portandola alle 

dimensioni che desideriamo dare ai frames del videoclip. Sistemiamo l’aspetto della molecola con i pulsanti 

“Traslazione” “ Rotazioni” e “Zoom”.  Selezioniamo la frequenza di vibrazione desiderata e clicchiamo sul 

tasto “Play” della finestra “Vibration”. Dopo aver fermato la vibrazione (tasto “Stop”) possiamo ottenerne i 

frames selezionando la voce “Create a film”, selezionando il formato dei frames (meglio PNG o POV) e la 

cartella dove verranno salvati (Folder). A questo punto la pressione del tasto “Play” anima la molecola e 

contemporaneamente genera i frames. 



 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto. Se i frames sono troppo grandi o hanno larghezza e altezza dispari si può 

usare il filtro “Crop” di Virtualdub2.  

Di seguito i due videoclip ottenuti con i frames PNG e con i files POV 

 

Mercaptopropanone_ freq_Gabedit.mp4 (5 kB)  Mercaptopropanone_ freq_Gabedit_POV.mp4 (9 kB) 

***** 

Proviamo ora a disegnare una molecola con l’editor di Gabedit e ad eseguire una simulazione di dinamica 

molecolare utilizzando il campo di forze AMBER usato da Gabedit. Apriamo l’Editor cliccando sull’icona 

“Draw geometry”. 

 

Clicchiamo sull’icona “Insert/Change atoms or bond” e si attiverà automaticamente anche il pulsante 

sottostante “Set atom to insert” che permette di accedere ad una tabella periodica per definire l’elemento 

attivo. Controlliamo che sia attivato anche il pulsante “Adjust hydrogens” in modo che vengano 

automaticamente aggiunti gli atomi di Idrogeno necessari.  



 

Ovviamente di “default” l’elemento attivo è il Carbonio. Un “clic sinistro” genera quindi un atomo di 

Carbonio con i suoi 4 idrogeni (metano CH4). Se l’elemento attivo fosse l’Ossigeno si formerebbe una 

molecola d’acqua H2O, se fosse l’Azoto avremmo una molecola di ammoniaca NH3. Un “clic sinistro + 

trascina” genera 2 atomi di carbonio legati da un legame semplice con i loro atomi di idrogeno (Etano 

CH3CH3). Un “clic sinistro” su di un atomo lo sostituisce con l’elemento attivo (completo dei suoi idrogeni), 

mentre su di un legame ne aumenta l’ordine di legame ( da semplice a doppio, da doppio a triplo, da triplo 

a semplice) modificando automaticamente il numero di atomi di idrogeno legati. 

Proviamo a costruire una molecola. Clic sinistro è compare una molecola di metano CH4. Prima di procedere 

conviene centrarla sulla finestra di visualizzazione, cliccando sull’icona “Optimal camera”  e portarla in 

primo piano eseguendo uno zoom dopo aver cliccato sull’icona . 

Riclicchiamo sul pulsante  e poi clicchiamo su un atomo di idrogeno per sostituirlo con uno di Carbonio 

(completo dei suoi idrogeni).  

 

 

 

Clicchiamo due volte sul legame C-C per trasformarlo in un triplo legame (otteniamo una molecola di Etino 

HC≡CH).  

 

Gabedit ha aggiornato il numero di atomi di Idrogeno, ma non la geometria che dovrebbe essere lineare. 

Clicchiamo ora sull’icona , scegliamo l’Ossigeno e andiamo a sostituire un atomo di Idrogeno dell’Etino 

con un atomo di Ossigeno completo di Idrogeno (un Ossidrile OH).  



 

Abbiamo ottenuto una molecola di Etinolo, ma l’ossidrile dovrebbe presentare un angolo di legame, 

mentre è lineare. Il risultato sarebbe stato migliore se avessimo sostituito l’idrogeno con l’ossidrile 

prelevato dai gruppi funzionali (residui) già pronti. Proviamo a farlo. Clicchiamo sull’icona “Insert a 

fragment”  e dalla finestra che si apre  apriamo il menu “Functionals” e scegliamo “Hydroxy” (come si 

può vedere vi sono numerosi gruppi funzionali già pronti da poter inserire in una molecola in costruzione). 

 

Ora clicchiamo sull’altro idrogeno e lo sostituiamo con l’ossidrile. 

 

Abbiamo ottenuto una molecola di Etindiolo, la cui geometria ha tuttavia bisogno di essere ottimizzata 

(piegando un ossidrile e rendendo lineare il triplo legame C-C). Facciamo un clic-destro sulla molecola e dal 

menu che compare scegliamo “Amber potential > Optimization”.  Il risultato non è del tutto soddisfacente. 

L’ossidrile si è piegato (ma la lunghezza dei due legami O-H è diversa), ma non abbiamo raddrizzato il triplo 

legame C-C. Il risultato sarebbe migliore se usassimo i programmi esterni di Dinamica molecolare a cui 

Gabedit si appoggia. Un risultato migliore si otterrebbe facendo un clic destro e scegliendo dal menu che 

compare “(semi-)Empirical > Mopac Optimization”. Mopac è un programma di dinamica molecolare 

freeware che ha tuttavia bisogno di richiedere una password gratuita per essere installato ed ha una 

procedura di installazione non semplicissima. Il risultato è comunque il seguente 

 



Mopac genera anche un file con estensione AUX che contiene tutte le strutture analizzate nel corso 

del’ottimizzazione  ad energia via via decrescente che Gabedit carica automaticamente e mostra in un 

grafico. 

 

Cliccando su ogni punto viene automaticamente mostrata la struttura corrispondente.  

Il file AUX può essere ricaricato da Gabedit  e trasformato in un’animazione che ripercorre tutte le strutture 

analizzate lungo il percorso di convergenza. Clicchiamo il pulsante  “Display Geometry..” e nella finestra  

“Orbital/Density/Vibration” che si aprirà clicchiamo sul menu “M > Animation > several geometries 

(Convergence/IRC)”. Nella finestra “Multiple geometries” che si aprirà clicchiamo su “File > Read > Read a 

Mopac aux file” e carichiamo il file AUX precedentemente generato. Come  abbiamo già visto in 

precedenza, selezioniamo la voce “Create a film”, selezioniamo il formato dei frames (meglio PNG o POV) e 

la cartella dove verranno salvati (Folder). A questo punto la pressione del tasto “Play” anima la molecola e 

contemporaneamente genera i frames. Il risultato, ottenuto convertendo i frames con virtualdub2, è il 

seguente. 

Etindiolo_Gabedit.mp4 (20 kB) 

Il file AUX può essere caricato, animato e trasformato in un videoclip anche da Molden, come vedremo più 

avanti. 

***** 

Il processo di ottimizzazione  può esser fatto in modo più semplice ed efficace facendo un clic destro e 

scegliendo dal menu che compare “(semi-)Empirical > OpenBabel Optimization”. OpenBabel è un 

programma Freeware in grado di eseguire conversioni di formati molecolari, ma anche di eseguire 

ottimizzazioni. È sufficiente installarlo in “C:\OpenBabel”  (Gabedit lo cerca lì e non c’è verso di fargli 

cambiare le cartelle dove sono installati i programmi a cui si appoggia anche se in teoria ci permette di 

farlo). OpenBabel può usare in alternativa 3 campi di forza (MMFF94, UFF e GHEMICAL). Con MMFF94 e 

UFF il risultato è molto buono. 

 

È tuttavia possibile che I metodi di ottimizzazione finiscano per trovare un “minimo relativo o locale” di 

energia potenziale e che esistano altre conformazioni ad energia minore. È possibile allora usare le opzioni 



di Dinamica molecolare di Gabedit per cercare altri conformeri. Costruiamo ad esempio con l’Editor di 

Gabedit una molecola di Etano in conformazione eclissata, con i 3 idrogeni anteriori che ricoprono i 3 

idrogeni posteriori. Per farlo dobbiamo cliccare sull’icona “Move selected atom”  che ci permette di 

trascinare gli atomi in una posizione diversa. Quindi sostituiamo due atomi di idrogeno sovrapposti con due 

atomi di Iodio, fino ad ottenere una molecola di 1,2-diIodoetano in conformazione eclissata-syn (la meno 

stabile perché gli atomi sono troppo vicini). 

 

Ora facciamo un clic-destro sulla molecola e dal menu che compare scegliamo “Amber potential > 

Optimization”.   Otteniamo la conformazione sfalsata-gauche che tuttavia non è la più stabile, ma 

rappresenta un minimo relativo di energia potenziale. 

 

Eseguiamo una ricerca di altre conformazione. Un clic-destro sulla molecola e dal menu che compare 

scegliamo “Amber potential > Molecular Dynamics Conformational search”. Nella finestra che si apre 

scegliamo la cartella (Folder) in cui verranno salvati i files prodotti dalla simulazione (“Conf.gab” con le 

conformazioni trovate e “Traj.gab” con la traiettoria percorsa dalla molecola). Andiamo sulla scheda 

successiva “Molecular Dynamics” e mettiamo un segno di spunta sulla voce “Save trajectory in” in modo 

che la traiettoria si salvi nel file “Traj.gab”.  

 

 



A questo punto clicchiamo su “OK” e osserviamo la molecola contorcersi mentre il programma simula un 

aumento di Temperatura per farla uscire dal minimo locale di energia alla ricerca di altri minimi 

(conformazioni). Al termine viene creato il file “Conf.gab” che Gabedit carica in automatico in cui sono 

presenti due conformazioni: quella ad energia più alta è la “Sfalsata-gauche” da cui eravamo partiti, 

mentre quella ad energia più bassa e la “sfalsata-anti” con in due atomi di Iodio in posizioni opposte. 

                       

Il file “Traj.gab”può essere ricaricato da Gabedit  e trasformato in un’animazione che ripercorre tutte le 

strutture analizzate durante la simulazione. Clicchiamo il pulsante  “Display Geometry..” e nella finestra  

“Orbital/Density/Vibration” che si aprirà clicchiamo sul menu “M > Animation > Molecular dynamic 

trajectory”. Nella finestra che si aprirà clicchiamo su “File > Read > Read a Gabedit file” e carichiamo il file 

“Traj.gab” precedentemente generato. Come  abbiamo già visto in precedenza, selezioniamo la voce 

“Create a film”, selezioniamo il formato dei frames (meglio PNG o POV) e la cartella dove verranno salvati 

(Folder). A questo punto la pressione del tasto “Play” anima la molecola e contemporaneamente genera i 

frames. Il risultato, ottenuto convertendo i frames con virtualdub2, è il seguente. 

diIodoEtano_Gabedit.mp4 (154 kB) 

Dal menu della stessa finestra che abbiamo usato per creare i frames possiamo infine scegliere “File > Save 

as PDB file”  e salvare la traiettoria come file “PDB multiplo” che può essere letto e trasformato in un 

videoclip da Chimera, Sirius, JMOL e VMD (come abbiamo già visto). 

Di seguito il videoclip ottenuto con VMD. 

diIodoEtano_Gabedit_(VMD).mp4 (155 kB) 

***** 

Allo stesso modo Gabedit è in grado di caricare e trasformare in videoclip anche traiettorie di 

ottimizzazione in formato XYZ come quelle generate, come vedremo in seguito, da MoCalc (tramite i 

programmi di Dinamica molecolare Mopac, Firefly e NWChem). Il file XYZ va caricato  cliccando il pulsante 

 “Display Geometry..” e nella finestra  “Orbital/Density/Vibration” che si aprirà cliccando sul menu 

several geometries (Convergence/IRC)”. Nella finestra “Multiple geometries” che si aprirà clicchiamo su 

“File > Read > Read a XYZ file”. Come  abbiamo già visto in precedenza, selezioniamo la voce “Create a 

film”, selezioniamo il formato dei frames (meglio PNG o POV) e la cartella dove verranno salvati (Folder). Il 

videoclip ottenuto è visualizzabile nella sezione dedicata a MoCalc. 

***** 

Gabedit è in grado di creare anche semplici videoclip di molecole in rotazione. Clicchiamo il pulsante  

“Display Geometry..” e nella finestra  “Orbital/Density/Vibration” che si aprirà clicchiamo sul menu “M > 

Geometry > Read the geometry from a pdb file” per caricare un file PDB, ad esempio una molecola di 



ammoniaca NH3.  Clicchiamo ora sul menu “M > Animation > Rotation”. Come  abbiamo già visto in 

precedenza, selezioniamo la voce “Create a film”, selezioniamo il formato dei frames (meglio PNG o POV) e 

la cartella dove verranno salvati (Folder). Impostiamo il valore di  “Number of rotation by Cicle” a 50 in 

modo che una rotazione completa avvenga in 50 frames (e dunque poiché poi setteremo il framerate a 25 

fps, la rotazione e il videoclip dureranno 2 secondi).  

 

A questo punto la pressione del tasto “Play” anima la molecola e contemporaneamente genera i frames. Il 

risultato, ottenuto convertendo i frames con virtualdub2, è il seguente. 

ammoniaca_Gabedit.mp4 (38 kB) 

***** 

Gabedit legge e può trasformare in animazioni anche i file AUX generati da Mopac tramite MoCalc. ). Più 

avanti vedremo come generare con MoCalc il file AUX che usiamo qui con Gabedit. Ma in questo caso il file 

AUX contiene informazioni sia sulla traiettoria di ottimizzazione, sia sulle frequenze vibrazionali che sugli 

orbitali molecolari. Apriamo dunque Gabedit, clicchiamo sul pulsante  “Display Geometry..” e nella 

finestra  “Orbital/Density/Vibration” che si aprirà clicchiamo sul menu “M > Animation > several 

geometries (Convergence/IRC)”. Nella finestra “Multiple geometries” che si aprirà clicchiamo su “File > 

Read > Read a Mopac aux file” e carichiamo il file AUX precedentemente generato. Come  abbiamo già 

visto in precedenza, selezioniamo la voce “Create a film”, selezioniamo il formato dei frames (meglio PNG o 

POV) e la cartella dove verranno salvati (Folder). 

Per visualizzare le frequenze vibrazionali riapriamo lo stesso file AUX utilizzando il menu “M > Animation > 

vibration” Nella finestra “Vibration” che si aprirà clicchiamo su “File > Read > Read a Mopac aux file” e 

carichiamo il file AUX. Scegliamo una frequenza e procediamo come abbiamo fatto in precedenza per la 

traiettoria di convergenza.  

Infine per visualizzare gli orbitali molecolari riapriamo il file AUX utilizzando il menu “M > Orbitals > Read 

Geometry and orbitals from a Mopac aux file”. Un doppio clic su uno degli orbitali che ci vengono 

presentati nella finestra “Orbitals” e poi “OK” fino ad ottenere la rappresentazione dell’orbitale.  

Clicchiamo ora sul menu “M > Animation > Rotation”. Come  abbiamo già visto in precedenza, 

selezioniamo la voce “Create a film”, selezioniamo il formato dei frames (meglio PNG o POV) e la cartella 

dove verranno salvati (Folder). Impostiamo il valore di  “Number of rotation by Cicle” a 50 in modo che una 

rotazione completa avvenga in 50 frames (e dunque poiché poi setteremo il framerate a 25 fps, la rotazione 

e il videoclip dureranno 2 secondi).  



Di seguito i videoclip di una frequenza vibrazionale e di un orbitale molecolare (in POVray) ottenuti 

convertendo i frames con virtualdub2. 

Urea_freq_gabedit.mp4 (3 kB)  e Urea_orbit_gabedit.mp4 (74 kB)   

***** 

Gabedit è in grado di caricare e trasformare in videoclip anche le vibrazioni generate da MoCalc tramite 

Firefly o NWChem. Più avanti vedremo come generare con Firefly il file GAM (e con NWCHem il file NWO)  

contenente le vibrazioni del’Etanolo che usiamo qui con Gabedit. Clicchiamo sul pulsante  “Display 

Geometry..” e nella finestra  “Orbital/Density/Vibration” che si aprirà clicchiamo sul menu “M > 

Animation > vibration”. Nella finestra “Vibration” che si aprirà clicchiamo su “File > Read > Read a Gamess 

output file” per caricare il file GAM oppure su “File > Read > Read a NWChem output file” per caricare il 

file NWO . Gabedit non ci propone di cercare file con estensione GAM o NWO per cui è necessario 

selezionare l’asterisco (*) nel menu in basso a destra di selezione del tipo di file mostrati in modo che ci 

vengano mostrati i file con tutte le estensioni. 

 

Carichiamo il file GAM (o il file NWO), scegliamo una frequenza e procediamo come abbiamo fatto in 

precedenza.  Il risultato è il seguente. 

Etanolo_Firefly(Gabedit_freq).mp4 (4 kB) 

***** 

Il file GAM generato da Firefly e il file NWO generato da NWChem contengono anche orbitali che Gabedit è 

in grado di visualizzare. Riapriamo quindi il file GAM utilizzando il menu “M > Orbitals > Read Geometry 

and orbitals from a Gamess output file” (o il file NWO utilizzando il menu “M > Orbitals > Read Geometry 

and orbitals from a NWChem output file”). Una volta aperto il file procediamo come abbiamo fatto in 

precedenza per gli orbitali contenuti nel file AUX. Una volta ottenuta la rappresentazione dell’orbitale 

clicchiamo sul menu “M > Animation > Rotation”. Come  abbiamo già visto in precedenza, selezioniamo la 

voce “Create a film”, selezioniamo il formato dei frames (meglio PNG o POV) e la cartella dove verranno 

salvati (Folder). Impostiamo il valore di  “Number of rotation by Cicle” a 50 in modo che una rotazione 

completa avvenga in 50 frames (e dunque poiché poi setteremo il framerate a 25 fps, la rotazione e il 

videoclip dureranno 2 secondi).  Il risultato è il seguente. 



Etanolo_Firefly(Gabedit_orb).mp4 (50 kB) 

Torna all’indice 

OpenMM Zephyr e Gromacs 

OpenMM Zephyr 2.0.3 è una Interfaccia Grafica (GUI) per il programma freeware di Chimica 

computazionale Gromacs che esegue calcoli di Dinamica Molecolare essenzialmente su strutture proteiche.  

Zephyr va installato in C:\Zephyr e contiene già al suo interno Gromacs. Se è installato, Zephyr si interfaccia 

con VMD e lo carica durante la simulazione, utilizzandolo per visualizzare la traiettoria. 

Le simulazioni di dinamica molecolare su grosse molecole proteiche possono durare diverse ore, quindi 

scegliamo una proteina di piccole dimensioni (peptide) con codice PDB = 1FME, che scarichiamo dal sito 

www.rcsb.org. 

Apriamo Zephyr, clicchiamo sul pulsante “Browse molecule (PDB) files..” per caricare il file PDB, scegliamo 

la cartella (“Choose output folder”) in cui verranno salvati i file generati da Gromacs. 

 

Andiamo infine sulla scheda “Parameters” e clicchiamo su “Simulate”. Se VMD è installato si aprirà e 

visualizzerà la traiettoria molecolare. 

Alla fine della simulazione verranno prodotti (tra gli altri) i file “1fme_processed.box.em.md.gro”, 

“1fme_processed.box.em.md.tpr” e il file traiettoria “1fme_processed.box.em.md.trr”, utilizzabili per 

ottenere animazioni e videoclip con VMD e con Chimera. 

Per ottenere un videoclip con VMD carichiamo da menu “File > New molecule” prima il file GRO e poi il file 

traiettoria TRR. Per ottenere i frames da trasformare in videoclip clicchiamo il menu "Extensions > 

Visualization > Movie maker" e seguiamo le istruzioni già viste in precedenza. 

Ed ecco il risultato 



 peptide_Zephyr_(Gromacs-VMD).mp4 (342 kB) 

Per ottenere un videoclip con Chimera clicchiamo su menù "Tools > MD/Ensemble > MD Movie" e alla 

voce “Trajectory Format” selezioniamo "Gromacs” e carichiamo il file TPR e il file TRR, clicchiamo infine su 

“OK” e seguiamo le istruzioni già viste in precedenza. 

Ed ecco il risultato 

 peptide_Zephyr_(Gromacs-Chimera).mp4 (342 kB) 

Ricordiamoci che una volta caricata una traiettoria, Chimera è in grado di salvarla in formato PDB multiplo 

che può essere riaperto e trasformato in un videoclip anche da JMol e Sirius. 

Torna all’indice 

Force Field Explorer (FFE) e Tinker 

Force Field Explorer 8.7 è una Interfaccia Grafica (GUI) per il programma freeware di Chimica 

computazionale Tinker che esegue calcoli di Dinamica Molecolare essenzialmente su strutture proteiche. Il 

programma si installa già completo di Tinker. Le simulazioni di Dinamica molecolare iniziano caricando un 

file PDB che verrà poi trasformato in un file  XYZ in formato Tinker che contiene le coordinate della 

molecola e i riferimenti al tipo di Campo di Forza (Force Field) da utilizzare. Tinker può utilizzare diversi 

campi di forza, principalmente AMBER e CHARMM per proteine e acidi nucleici, MM2 e MM3 per molecole 

organiche non proteiche. 

FFE-Tinker in genere non ha problemi con le proteine, mentre ha spesso difficoltà a generare i file XYZ per 

molecole organiche non proteiche. In quest’ultimo caso, come vedremo, è conveniente generare il file XYZ 

con OpenBabel o con Molden. 

Proviamo ora ad effettuare una simulazione di Dinamica molecolare con la Crambina (PDB = 1CRN), una 

piccola proteina presente nel Cavolo abissino. Apriamo FFE, clicchiamo su “Open” e carichiamo il file 

“1CRN.pdb” che abbiamo precedentemente scaricato o possiamo prelevarlo direttamente dal WEB 

cliccando sul menu “File > Download from PDB…” e immettendo il codice della proteina “1CRN”. 

 

Ci verrà chiesto di scegliere il campo di forza da utilizzare per i calcoli. Essendo una proteina possiamo 

scegliere un campo, AMBER, CHARMM o AmoebaPro. 



 

A questo punto dobbiamo generare il file XYZ di input per Tinker. Apriamo la scheda “Modeling 

Commands”. Dal menu a discesa con i possibili comandi (solo 3 finché non è generato il file XYZ) scegliamo 

“PDBXYZ” e clicchiamo su “GO”. 

 

Se il comando è andato a buon fine nella finestra di sinistra verrà caricato il file XYZ, mentre il menu a 

discesa della scheda “Modeling Commands” si arricchirà di nuovi comandi dai quali selezioniamo 

“Dynamic” e poi clicchiamo su “GO” per far iniziare la simulazione. 

 

Sulla barra inferiore di osserverà lo stato di avanzamento del calcolo. Alla fine della simulazione la 

traiettoria viene salvata come file ARC che può essere caricato da FFE e visualizzato come animazione, ma 

non salvato in un videoclip.  Il videoclip si può ottenere caricando il file ARC con Jmol o con Molden. 

Per ottenere un videoclip carichiamo il file ARC con Jmol. Creiamo all’interno della cartella di installazione 

di Jmol una cartella “frames” dove verranno memorizzati i frames della traiettoria e all’interno della 

Console a linea di comando scriviamo 

write frames {*} 368 286 "frames/all.png" 

dove 368 e 286 sono le dimensioni (larghezza x altezza) che avranno i frames (ma possiamo dare qualsiasi 

valore). 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto. Il risultato è il seguente 



Crambina_Tinker(Jmol).mp4 (190kB) 

***** 

Eseguiamo ora un’altra simulazione con Tinker, usando una molecola non proteica, ad esempio una 

molecola di Etanolo CH3CH2OH in formato PDB. 

In questo caso la conversione in formato Tinker XYZ con FFE incontra problemi. È necessario effettuare la 

conversione con OpenBabel, che produce un file Tinker XYZ settato per utilizzare un force Field MM2 o con 

Molden che carica il PDB con il pulsante “Read” e lo salva come XYZ (Force Field MM3) con il pulsante 

“Write > Tinker” all’interno della sua cartella di installazione. 

Apriamo FFE, clicchiamo su “Open” e carichiamo il file “Etanolo.xyz”. Ci verrà chiesto di scegliere il campo di 

forza da utilizzare per i calcoli. Scegliamo MM2 o MM3 a seconda che il file XYZ sia stato ottenuto con 

OpenBabel o con Molden. Apriamo la scheda “Modeling Commands” e dal menu a discesa dei comandi 

scegliamo “Vibrate”.  Nella casella in cui indicare quali vibrazioni vogliamo calcolare scriviamo “A” (A = All = 

tutte) ed infine facciamo partire la simulazione cliccando su “GO”. 

 

Al termine della simulazione verrà creato un file per ciascuna vibrazione con estensione .001 .002 . 003 etc 

Apriamo Jmol e carichiamo uno dei file-vibrazione. Jmol lo vedrà come “animazione” e non come 

“vibrazione”. Per vedere il movimento clicchiamo sul menu “Strumenti > Anima > palindromo”. Per 

ottenere i frames scriviamo nella Console 

write frames {*} 320 240 "frames/all.png" 

dove 320 e 240 sono le dimensioni (larghezza x altezza) che avranno i frames (ma possiamo dare qualsiasi 

valore). 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto. Il risultato è il seguente 

Etanolo_Tinker(Jmol).mp4 (11 kB) 

 

Torna all’indice 



Molden 

Anche Molden (oltre a Jmol) è in grado di trasformare una traiettoria in formato ARC in un videoclip. 

Apriamo dunque Molden e clicchiamo sul pulsante “Read” per caricare il file “1CRN.arc” prodotto con FFE-

Tinker.  

 

Usiamo poi il menu “Draw Mode” per definire l’aspetto della molecola. Cliccando su “Backbone” compare 

la strutture secondaria della proteina, mentre cliccando su “Solid” possiamo scegliere l’aspetto “Stick”, 

“Ball&stick” o “Spacefill” degli atomi e dei legami. 

Clicchiamo sul pulsante “Movie” per vedere l’animazione. Dopo aver controllato che l’animazione avvenga 

correttamente, clicchiamo sul terzo pulsante centrale  e nella finestra che si aprirà deselezioniamo il 

pulsante “Clean up snap shots when done” in modo che i frames generati da Molden non vengano 

cancellati una volta creata l’animazione (che Molden ci propone di registrare in un file “molden.avi”) 

 

Ora clicchiamo sul pulsante “Record”. La registrazione partirà solo quando cliccheremo anche il pulsante 

“Movie”. Molden esegue infatti delle fotografie (“snapshot”) della finestra di visualizzazione della molecola 

solo mentre quest’ultima si anima. Quando l’animazione finisce e la molecola si ferma, clicchiamo su “Stop 

& Create movie”. Molden salva i frames (in formato BMP) e l’animazione all’interno della sua cartella di 

installazione. Molden non sempre riesce a costruire correttamente il file “molden.avi” e, quando ci riesce, si 

tratta di un file in formato MPEG-2, obsoleto e poco efficiente. 



Una volta generati i frames sarà quindi consigliabile caricare il primo frame con Virtualdub2 per generare il 

videoclip mp4 come abbiamo già visto. Il risultato è il seguente 

Crambina_Tinker(Molden).mp4 (500kB) 

***** 

Allo stesso modo Molden è in grado di caricare e trasformare in videoclip anche traiettorie di 

ottimizzazione in formato XYZ come quelle generate, come vedremo in seguito, da MoCalc (tramite i 

programmi di Dinamica molecolare Mopac, Firefly e NWChem). Il videoclip ottenuto è visualizzabile nella 

sezione dedicata a MoCalc. 

***** 

Molden legge anche i file-vibrazione che abbiamo generato con FFE-Tinker per la molecola di Etanolo. 

Apriamo dunque Molden e carichiamo uno dei file-vibrazione cliccando sul pulsante “Read”. Usiamo poi il 

menu “Draw Mode” per definire l’aspetto della molecola. Clicchiamo sul pulsante “Movie” per vedere 

l’animazione. Dopo aver controllato che l’animazione avvenga correttamente, clicchiamo sul terzo pulsante 

centrale  e nella finestra che si aprirà deselezioniamo il pulsante “Clean up snap shots when done” in 

modo che i frames generati da Molden non vengano cancellati una volta creata l’animazione. 

Ora clicchiamo sul pulsante “Record” e poi  sul pulsante “Movie”. Quando l’animazione finisce e la 

molecola si ferma, clicchiamo su “Stop & Create movie”. Molden salva i frames (in formato BMP) e 

l’animazione all’interno della sua cartella di installazione.  Una volta generati i frames sarà quindi 

consigliabile caricare il primo frame con Virtualdub2 per generare il videoclip mp4 come abbiamo già visto.  

Il primo frame è in formato GIF, probabilmente per un bag, e può essere tralasciato. Il risultato è il seguente 

con l’opzione “Perspective” selezionata e deselezionata. 

Etanolo_Tinker(Molden_persp).mp4 (10kB)        Etanolo_Tinker(Molden).mp4 (10kB) 

***** 

Molden è in grado di caricare e trasformare in videoclip anche le vibrazioni generate da MoCalc tramite i 

programmi di Dinamica molecolare Firefly o NWChem. Più avanti vedremo come generare con Firefly il file 

GAM (e con NWCHem il file NWO)  contenente le vibrazioni del’Etanolo che usiamo qui con Molden. 

Dopo aver caricato il file GAM (o il file NWO)  usando il pulsante “Read”, clicchiamo sul pulsante 

“Frequencies  > Norm. mode”. Nella finestra “Molden Frequency Select” che compare, clicchiamo sulle 

diverse frequenze e la molecola comincerà a vibrare di conseguenza.  

Una volta soddisfatti della vibrazione visualizzata, clicchiamo sul terzo pulsante centrale  e nella finestra 

che si aprirà deselezioniamo il pulsante “Clean up snap shots when done” in modo che i frames generati da 

Molden non vengano cancellati una volta creata l’animazione. Ora clicchiamo sul pulsante “Record” e poi  

su “Stop & Create movie”. Il risultato è il seguente. 

Etanolo_Firefly(Molden_freq).mp4 (14 kB) 

 



 

Torna all’indice 

MoCalc 2012 (Mopac – FireFly  – Gamess – NWChem) 

Mocalc è una interfaccia grafica (GUI) per numerosi programmi di Chimica computazionale e Dinamica 

molecolare, molti dei quali sono freeware (MOPAC, FIREFLY, GAMESS, NWCHEM). Mocalc presenta una 

guida dettagliata su come tali programmi devono essere installati e configurati. 

Apriamo MoCalc ed eseguiamo una simulazione di Dinamica molecolare con Mopac cliccando sul relativo 

pulsante. Ora dobbiamo procurarci una molecola. Clicchiamo sul menu “Start”. Possiamo scegliere di 

caricare un molecola che già possediamo usando “Open Structure file” oppure disegnare la molecola con il 

comando “Draw Structure with…” utilizzando programmi di editing molecolare online (JSME, CH5M3D) o 

programmi installati sul nostro PC e che MoCalc ha individuato. In questo caso usiamo il comando “Import 

Structure from…” che ci permette di scaricare molecole da PubChem o da Protein Data Bank 

 

Una veloce ricerca sul WEB inserendo la voce “Urea PubChem CID” ci fornisce il codice PubChem CID = 

1176.  Nella finestra che si apre scegliamo la voce “CID (PubChem)” inseriamo il codice “1176”, clicchiamo 

sulla cartella in basso a destra per scegliere la cartella in cui verrà salvato il file SDF scaricato dal sito 

PubChem e in cui verranno salvati anche tutti i file della simulazione. Clicchiamo infine su “Start”. 

 

Scegliamo ora come tipo di simulazione “”Optimize + Vibrational Frequencies” e clicchiamo infine su “Run 

MOPAC!”. 



 

Alla fine della simulazione verranno prodotti diversi file tra i quali utilizzeremo AUX (vibrazioni + orbitali), 

MNO (vibrazioni), MGF (orbitali) che potremmo caricare e trasformare in animazioni e videoclip, utilizzando 

Jmol e Gabedit (come abbiamo già visto). Viene anche generata una traiettoria di ottimizzazione in formato 

XYZ che possiamo trasformare in animazioni e videoclip utilizzando Jmol, VMD, PyMol , IQmol, Gabedit e 

Molden (con le modalità già viste) e che vedremo come trasformare in videoclip anche con Molekel e 

Avogadro. 

Cliccando sul pulsante “Vibrations” viene anche generato un file JDX che contiene le vibrazioni e che 

MoCalc carica direttamente utilizzando Jmol (solo se Jmol è installato e abbiamo indicato a MoCalc dove 

trovarlo) che ci mostrerà sia la molecola che vibra, sia il grafico delle frequenze (caricato utilizzando 

JSpecView). Cliccando su di una frequenza sul grafico viene visualizzata la corrispondente vibrazione della 

molecola. Il file JDX può essere in seguito ricaricato con il menu “File >Apri” di Jmol. 

 

***** 

Riapriamo MoCalc ed eseguiamo una simulazione di Dinamica molecolare con Firefly cliccando sul relativo 

pulsante. Firefly, un tempo noto come PC GAMESS, è un programma di chimica computazionale, basato su 

GAMESS US. Firefly genera lo stesso tipo di file di output prodotti da Gamess. Con Firefly scegliamo di fare 

una ottimizzazione e quindi su “Job Type” selezioniamo la voce “ Geometry Optimization”. Ora dobbiamo 

procurarci una molecola da ottimizzare. Con Gabedit costruiamo una molecola di Etanolo in conformazione 

eclissata, con l’ossidrile con un errato angolo di legame di 180° e l’atomo di Idrogeno opposto all’ossidrile 

che presenta un legame C-H troppo lungo.  



 

Clicchiamo sul menu “Start”, carichiamo l’Etanolo utilizzando il menu “Open Structure file” e clicchiamo 

infine su “Run Firefly!”. Alla fine della simulazione verranno prodotti diversi file tra i quali la traiettoria di 

ottimizazione XYZ, che possiamo trasformare in animazioni e videoclip utilizzando Jmol, VMD, PyMol , 

IQmol, Gabedit e Molden (con le modalità già viste) e che vedremo come trasformare in videoclip anche 

con Molekel e Avogadro. 

Cliccando sul pulsante “Geometry Convergence” Mocalc ci presenta un grafico che mostra il percorso di 

convergenza della molecola attraverso  tutte le strutture analizzate nel corso dell’ottimizzazione  ad energia 

via via decrescente.  

 

Cliccando sul menu “Animation > Play”  MoCalc  genera una pagina HTML che carica attraverso Jsmol, 

l’implementazione WEB di Jmol (ovviamente solo se Jmol è installato e abbiamo indicato a MoCalc dove 

trovarlo). La pagina mostra  la molecola che si contorce attraverso la sua traiettoria di ottimizzazione, 

(avvicinando l’idrogeno troppo distante, assumendo la conformazione sfalsata e piegando l’ossidrile) 

mentre nel grafico sulla destra vedremo i corrispondenti valori di energia. 

 



Cliccando invece sul menu “Animation > Save picture for movie”,  MoCalc  utilizza Jmol per creare dei 

frames in formato JPEG che possono essere trasformati in un videoclip.  Di seguito il file mp4 ottenuto con 

Virtualdub2. 

etanolo_Firefly(Jmol).mp4 (44 kB) 

Mentre i seguenti sono i videoclip ottenuti (con le modalità che abbiamo già visto in precedenza) da VMD, 

PyMOL, Gabedit e Molden 

Etanolo_Firefly(VMD).mp4  (96 kB)                 Etanolo_Firefly(PyMol).mp4 (43 kB) 

Etanolo_Firefly(Gabedit).mp4 (78 kB)            Etanolo_Firefly(Molden).mp4  (79 kB) 

Come era già successo a IQmol, anche Jmol e Gabedit non riescono a leggere correttamente il legame C-H 

troppo lungo e lasciano l’atomo di idrogeno isolato. 

Salviamo infine la molecola ottimizzata cliccando su “Save Output Structure…” e ricarichiamola da menu 

“Start > Open Structure File…”. Ora possiamo eseguire sulla molecola ottimizzata una nuova simulazione. 

Su “Job Type” selezioniamo la voce “ Vibrational Frequencies” e clicchiamo infine su “Run Firefly!”.  Alla 

fine della simulazione verranno prodotti diversi file tra i quali un file GAM, che contiene le frequenze 

vibrazionali e gli orbitali molecolari. Il file GAM può essere trasformato (come abbiamo già visto) in 

animazioni e videoclip utilizzando Jmol, , IQmol, Gabedit e Molden. Come vedremo anche Molekel legge e 

trasforma in animazioni le vibrazioni contenute nei file GAM. 

***** 

Riapriamo MoCalc ed eseguiamo una simulazione di Dinamica molecolare con NWChem cliccando sul 

relativo pulsante. Proviamo ad eseguire le stesse due simulazioni che abbiamo fatto con Firefly sulla 

medesima molecola di Etanolo (prima una ottimizzazione e poi un calcolo delle frequenze vibrazionali sulla 

molecola ottimizzata). La prima simulazione genera un file XYZ (analogo a quello creato da Firefly-Gamess) 

contenente la traiettoria di ottimizzazione con il medesimo risultato finale. Come per Firefly la traiettoria 

XYZ è letta e trasformata in videoclip da  Jmol, VMD, PyMol , IQmol, Gabedit e Molden (con le modalità già 

viste) e, come vedremo, anche da Molekel e Avogadro. 

La seconda simulazione genera un file NWO che contiene, oltre alle vibrazioni, anche Orbitali molecolari. Il 

file NWO può essere trasformato (come abbiamo già visto) in animazioni e videoclip utilizzando Jmol, 

IQmol, Gabedit, Molden e Avogadro. 

Torna all’indice 

Molekel 

Molekel 5.4.0.8 è in grado di aprire numerosi formati molecolari tra i quali anche output di dinamica 

molecolare contenenti traiettorie e frequenze vibrazionali, che è in grado di trasformare in frames per 

animazioni. Dal menu “File > Open” carichiamo il file XYZ prodotto da Mopac, Firefly o da NWChem 

(tramite MoCalc) contenente la traiettoria di ottimizzazione dell’Etanolo. 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Rotazione in z (Ctrl + Clic sinistro + trascina), 



- Traslazione (Shift + Clic sinistro + trascina) 

- Zoom (Clic destro + trascina)  

 Clicchiamo sul menu “Animation > Per-Molecule Settings…” 

 

Nella finestra “Animation Preferences” che si aprirà impostiamo “animation = on” e “Animation Mode = 

Trajectory”. Apriamo la scheda “Trajectory” della stessa finestra e scegliamo la modalità di Loop (con 

“Swing” l’animazione va avanti e indietro producendo un effetto più fluido). 

 

Chiudiamo la finestra “Animation Preferences” e clicchiamo sul menu “Animation > Export Animation..”  e 

nella finestra che si apre impostiamo la durata dell’animazione (2 o 3 secondi dovrebbero essere sufficienti, 

ma dipende dal numero di frames contenuti nella traiettoria e quindi bisogna fare delle prove), il framerate 

a 25 fps e “Output Type = Individual Frames”.  



 

Diamo l’OK e indichiamo la cartella in cui vogliamo salvare i frames in formato PNG.  Di seguito il file mp4 

ottenuto con Virtualdub2. 

Etanolo_NWChem(Molekel_traj).mp4 (55 kB) 

***** 

Dal menu “File > Open” carichiamo il file GAM prodotto da Firefly (tramite MoCalc) contenente le vibrazioni 

dell’Etanolo precedentemente ottimizzata. Clicchiamo sul menu “Animation > Per-Molecule Settings…” 

Nella finestra “Animation Preferences” che si aprirà impostiamo “animation = on” e “Animation Mode = 

Vibration”. Chiudiamo la finestra “Animation Preference” e clicchiamo sul menu “Animation > Start 

Animation”. Clicchiamo nuovamente sul menu “Animation > Per-Molecule Settings…” e apriamo la scheda 

“Vibration”.  Qui possiamo selezionare le frequenze di vibrazione e vedere immediatamente l’effetto sulla 

molecola. È possibile anche selezionare più frequenze contemporaneamente. 

 

Quando saremo soddisfatti della frequenza selezionata, chiudiamo la finestra, fermiamo l’animazione e 

clicchiamo sul menu “Animation > Export Animation..”  dove eseguiremo le stesse operazioni viste in 

precedenza. Il file mp4 ottenuto convertendo i frames PNG con Virtualdub2 è il seguente. 

Etanolo_Firefly(Molekel_freq).mp4 (11 kB) 

Il file GAM contiene anche orbitali molecolari che Molekel è in grado di visualizzare da menu “Surfaces > 

Electron Density…”.  Nella finestra che si apre selezioniamo l’orbitale, mettiamo un segno di spunta sulla 



casella “Use both signs” in modo che vengano visualizzati sia i lobi positivi (blu) che quelli negativi (rossi), 

portiamo il valore di “step size” a 0,05 in modo che la superficie dell’orbitale sia più uniforme. 

Eventualmente si posso aumentare i valori “dx” “dy” e “dz” in modo che la “Bounding box” non tagli gli 

orbitali. Clicchiamo infine su “Generate” e su “Close”. 

 

Applichiamo ora una vibrazione con le modalità viste in precedenza. Quando saremo soddisfatti della 

frequenza selezionata, chiudiamo la finestra, fermiamo l’animazione e clicchiamo sul menu “Animation > 

Export Animation..”. Nella finestra che si apre impostiamo la durata dell’animazione (“Total time”), il 

framerate a 25 fps,  “Output Type = Individual Frames”, “Iso-surface Step = 0,1000” e mettiamo un segno 

di spunta sulle caselle “Use both signs” e “Map MEP on orbitals”. Clicchiamo “OK”. 

 

Quando verranno generati i frames gli orbitali modificheranno la loro forma per adattarsi ai movimenti 

della molecola. Di seguito il videoclip ottenuto trasformando i frames con Virtaldub2. 

Etanolo_Firefly(Molekel_freq+orb).mp4 (19 kB) 

Torna all’indice 



Avogadro 

Avogadro 1.2.0 è in grado di aprire numerosi formati molecolari tra i quali anche output di dinamica 

molecolare contenenti traiettorie e frequenze vibrazionali, che è in grado di trasformare in frames POV-ray 

per animazioni.  

Apriamo Avogadro e dal menu “File > Import > Molecule File..” carichiamo il file OUT, contenente le 

frequenze vibrazionali del Mercaptopropanone, che abbiamo generato utilizzando un server Web Q-Chem, 

attraverso il programma IQmol.  Alla voce “Format:” selezioniamo “Q-Chem output format”  

 

Assieme alla molecola compare sulla destra la lista delle frequenze vibrazionali.  Nella sezione “Display 

Types” sulla sinistra selezioniamo “Ball and Stick”.  

Per eventuali spostamenti della molecola deve essere attivato il pulsante “Navigation Tool” .  I comandi 

del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Traslazione (“Ctrl + Clic sinistro + trascina” o “clic destro + trascina”), 

- Zoom (“Shift + Clic sinistro + trascina” o “Rotella centrale”) 

Clicchiamo il pulsante “Start Animation” e selezioniamo le diverse frequenze finchè non troviamo quella 

che ci interessa. 

 

Con la molecola in movimento clicchiamo sul menu “Extension > Animation..” e nella finestra che compare 

clicchiamo su “Save as Avi…” 



 

Avogadro ci chiederà il nome del file da salvare e la cartella in cui salvarlo. In realtà con molta probabilità 

non riuscirà a creare il file AVI, ma nella cartella saranno registrati i file POV-Ray che potranno essere 

trasformati in frames BMP (con le modalità che abbiamo già visto) e quindi in un videoclip tramite 

Virtualdub2. Per una animazione più fluida è meglio scartare il primo frame. Il risultato finale è il seguente 

Mercaptopropanone_Q-Chem(Avogadro).mp4 (27 kB) 

***** 

Carichiamo ora il file XYZ prodotto da Mopac, Firefly o da NWChem (tramite MoCalc) contenente la 

traiettoria di ottimizzazione dell’Etanolo. 

Apriamo Avogadro e dal menu “File > Import > Molecule File..” carichiamo il file XYZ.  Alla voce “Format:” 

selezioniamo “Extended XYZ cartesian coordinates format”  

 

Clicchiamo sul menu “Extension > Animation..” e nella finestra che compare clicchiamo su “Save as Avi…”. 

Come visto in precedenza, verranno creati dei file POV che dovremmo trasformare in frames BMP (tramite 

POVRay con le modalità che abbiamo già visto) e quindi in un videoclip tramite Virtualdub2. Il risultato 

finale è il seguente 

Etanolo_NWChem(Avogadro_traj).mp4 (19 kB) 

***** 

Carichiamo infine il file NWO prodotto da NWChem (tramite MoCalc) contenente le frequenze vibrazionali 

dell’Etanolo precedentemente ottimizzato. 

Apriamo Avogadro e dal menu “File > Import > Molecule File..” carichiamo il file NWO.  Alla voce “Format:” 

selezioniamo “NWChem output format”  



 

Assieme alla molecola compare sulla destra la lista delle frequenze vibrazionali.  Clicchiamo il pulsante 

“Start Animation” e selezioniamo le diverse frequenze finché non troviamo quella che ci interessa. Con la 

molecola in movimento clicchiamo sul menu “Extension > Animation..” e nella finestra che compare 

clicchiamo su “Save as Avi…” 

Avogadro ci chiederà il nome del file da salvare e la cartella in cui salvarlo. In realtà con molta probabilità 

non riuscirà a creare il file AVI, ma nella cartella saranno registrati i file POV che potranno essere 

trasformati in frames BMP (tramite POV-Ray con le modalità che abbiamo già visto) e quindi in un videoclip 

tramite Virtualdub2. Per una animazione più fluida è meglio scartare il primo frame. Il risultato finale è il 

seguente 

Etanolo_NWChem(Avogadro_freq).mp4 (12 kB) 

***** 

Avogadro possiede anche un buon editor molecolare con un funzionamento analogo a quello di Gabedit. 

Per costruire una molecola assicuriamoci che in “Display Types” sia selezionato “Ball & Stick”. Clicchiamo 

sull’icona “Draw tools”  che farà comparire in basso a sinistra il menu “Draw settings” in cui potremo 

scegliere l’elemento attivo (come al solito il Carbonio è attivo di default).  Se in “Draw settings” la voce 

“Adjust Hydrogens” è selezionata tutti gli atomi introdotti presenteranno il giusto numero di atomi di 

Idrogeno. Con il Carbonio attivo un “clic sinistro” sulla finestra di visualizzazione (View) genera una 

molecola di Metano CH4, con l’Ossigeno attivo un “clic sinistro” produce una molecola di H2O, con l’Azoto 

attivo si forma Ammoniaca NH3. 

 

Il tasto “Canc” da tastiera cancella tutte le molecole. 

 



Con il Carbonio attivo un “clic sinistro + trascina” sulla finestra di visualizzazione (View) genera un legame 

tra due atomi di carbonio con i relativi atomi di idrogeno (una molecola di etano CH3CH3), con l’Ossigeno 

attivo un “clic sinistro + trascina” produce una molecola di perossido di idrogeno H2O2, con l’Azoto attivo si 

forma Idrazina NH2NH2. 

 

Un “clic sinistro” su di un atomo lo sostituisce con l’atomo attivo. Se clicchiamo sopra l’idrogeno di una 

molecola di metano CH4 con il Carbonio attivo lo trasformiamo in una molecola di Etano CH3CH3. Se 

clicchiamo sopra un idrogeno dell’Etano con l’Ossigeno attivo sostituiamo l’Idrogeno con un Ossidrile e 

otteniamo l’Etanolo. 

 

Un “clic sinistro” sopra un legame lo trasforma da semplice in doppio, da doppio in triplo e poi nuovamente 

da triplo in semplice.  Affinchè i legami multipli (doppi e tripli) siano visualizzati la voce “Stick” in “Display 

Types” deve essere deselezionata!! 

Se ad esempio clicchiamo sopra il legame C-O dell’Etanolo trasformiamo l’Ossidrile in un Carbonile. 

L’etanolo è stato trasformato in Etanale (Acetaldeide). 

Per poter cliccare più agevolmente su di un legame a volte è necessario allungarlo, trascinando un atomo 

dopo aver cliccato sull’icona “Manipulation Tool” . Poi è necessario ricliccare sull’icona “Draw tools” . 

 



Una volta completata la molecola è bene ottimizzarne la geometria.  Scegliamo prima il “Campo di forza” 

da utilizzare cliccando sul menu “Extensions  > Molecular Mechanics > Setup Force Field..”. I campi di forza 

disponibili sono “GAFF”, “Ghemical”, “MMFF94” e “UFF”. Una volta scelto il campo di forza clicchiamo sul 

menu “Extensions > Optimize Geometry”. 

Avogadro ci consente anche di trovare in Rete il nome IUPAC della molecola con il menù “View > Properties 

> Molecule Properties…” (che tuttavia non funziona per tutte le molecole). 

 

***** 

Avogadro ci consente di ottenere molecole anche in altri modi. 

1) Da menu “File > Import > Fetch from PDB…” è possibile scaricare proteine dalla Rete a patto di 

conoscerne il codice PDB 

2) Da menu “Build > Insert > SMILES…” è possibile inserire il codice SMILES della molecola (facilmente 

reperibile in rete). A differenza di Chimera in cui la caratteristica funziona molto bene, in Avogadro 

fallisce per molecole complesse e le molecole più semplici hanno comunque bisogno di essere 

ottimizzate. 

3) Da menu “Build > Insert > Fragments…” è possibile scegliere molte molecole già costruite e 

suddivise in famiglie. 

4) Da menu “Build > Insert > Peptide…” è possibile costruire sequenze di aminoacidi. 

5) Da menu “Build > Insert > DNA/RNA…” è possibile costruire sequenze di nucleotidi. 

Torna all’indice 

QuteMol 

QuteMol è in grado di caricare molecole in formato PDB e di trasformarle in 3 tipi di GIF animate delle 

dimensioni standard di 256 x 256 pixel. Apriamo QuteMol 0.4.1 e clicchiamo sull’icona  per caricare una 

molecola, ad esempio di Ammoniaca NH3. Clicchiamo sulla scheda “Preset” dove troviamo 15 diverse 

preselezioni. Proviamole finché l’aspetto della molecola non ci soddisfa. Clicchiamo sulla scheda 

“Geometry” che ci permette di decidere se la molecola apparirà in “Space-fill”, “Balls and Sticks” o 

“Licorice”. Clicchiamo infine sull’icona  per salvare l’animazione. Nella finestra “Save a snapshot” che si 



aprirà, alla voce “Salva come:” selezioniamo come tipo di file da salvare “GIF Animation”. Al momento di 

salvare il file si aprirà un’ulteriore finestra che ci chiederà di scegliere tra 3 tipi di animazione. I primi due 

sono “Full rotation mode” e “Inspection mode” (twist) che producono una gif animata della durata di 3 

secondi formata da 60 frames (e quindi con un framerate di 20 fps). Durata e numero di frames possono 

essere modificati. Di seguito i due videoclip ottenuti con la molecola di Ammoniaca che utilizza per la 

rotazione il preset “mixed 2” e per il “twist” il preset “Illustrative 1”. 

NH3_rot_QuteMol.gif  (163 kB)         NH3_twist_QuteMol.gif (229 kB) 

Se si vogliono ottenere file di dimensioni più contenute è possibile convertirli in MP4 utilizzando 

VIrtualdub2.  Apriamo Virtualdub2 e dal menu “File > Open video file…” carichiamo le animazioni GIF. Ora 

procediamo come abbiamo già visto quando abbiamo caricato i singoli frames.  

Dal menù “Video” selezioniamo “Full processing Mode”. Clicchiamo sul menu “Video > Frame rate…” e 

impostiamo a 20 fps.  Dallo stesso menù clicchiamo su “Compression…” e scegliamo ed impostiamo il codec 

“x264 8 bit” e poi clicchiamo su “Configure”.  Dopo aver impostato il “Tuning” su “Animation” possiamo 

impostare il livello di qualità (23 è il valore consigliato) o impostare il bitrate (100 kbps). 

Clicchiamo infine sul menù “File>Save video..” e nella finestra che si apre scegliamo in “salva come..” il 

formato “MP4 MPEG-4 part 14”. Ed ecco il risultato codificato con fattore di qualità = 23. 

NH3_rot_QuteMol.mp4  (34 kB)         NH3_twist_QuteMol.mp4 (40 kB) 

Ora proviamo il terzo tipo di animazione “Six-Sides mode” in cui la molecola viene fatta ruotare per 6 volte 

di 90 gradi sui 3 assi, mostrando tutte e 6 le sue facce e rimanendo ferma per 1 secondo su ogni faccia. 

L’intera animazione dura 7,8 secondi ed è composta di 60 frames di cui 6 frames durano 1 secondo (i 

frames associati alle pause) e gli altri frames durano 3 centesimi di secondo (i frames associati alle 

rotazioni). Di seguito il videoclip ottenuto con una molecola di Acido Acetilsalicilico (Aspirina) utilizzando il 

preset “Direct Light only”. 

Aspirina_sixmode_QuteMol.gif  (317 kB) 

In questo caso la conversione della GIF animata in MP4 usando Virtualdub2 non produce un risultato 

soddisfacente in quanto i frames GIF della durata di un secondo vengono trasformati in un unico frame 

della durata di 3 centesimi di secondo. In questo modo spariscono le pause di 1 secondo tra una rotazione e 

l’altra. L’unico programma che riesce a convertire correttamente una GIF animata in un MP4 è FFMPEG. 

Nel caso specifico, per ottenere la durata originale di 7,8 secondi il framerate è di 33.333 fps. La stringa in 

linea di comando che converte la gif animata “movie.gif” in un file “movie.mp4, con un livello di qualità pari 

a 23, è la seguente: 

ffmpeg -i movie.gif -movflags faststart -pix_fmt yuv420p -c:v h264 -crf 23 -r 33.333 movie.mp4 

Aspirina_sixmode_QuteMol.mp4  (69 kB) 

Se non si vuole utilizzare la linea di comando ci sono un paio di GUI freeware per FFMPEG che funzionano 

piuttosto bene: Moo0 Videoconverter 1.28  e VideoMass 2.0.0. 

Moo0 Videoconverter è di una semplicità disarmante. Alla voce “Converti in:” selzioniamo “MP4”. 

Clicchiamo su “Opzioni avanzate” e impostiamo la qualità del video “5 Cinematografico” (o scegliamo un 



bitrate tra quelli proposti). Impostiamo il framerate a 30 fps e infine trasciniamo il file da convertire 

nell’apposita “Area di rilascio”. Il file MP4 si forma nella stessa cartella in cui è contenuto il file GIF.  

 

VideoMass è un’ottima GUI italiana (di Gianluca Pernigotto) per FFMPEG. Apriamola e clicchiamo su 

“Conversioni Audio/Video” 

 

Trasciniamo il file da convertire all’interno della finestra che si apre. 

 



Clicchiamo sul menu “File > scegli una cartella di destinazione..” e selezioniamo la cartella in cui vogliamo 

venga registrato il file convertito. Clicchiamo sulla freccia nera verso destra per proseguire. Nella finestra 

che compare selezioniamo “x264” come Codec, scegliamo il livello di qualità (CRF = 23 è il default) o, 

cliccando su “Codifica a 2 passaggi”, scegliamo il Bitrate. Scegliamo 30 fps per il framerate (FPS) e come 

Formato Contenitore usiamo l’”MP4”. Clicchiamo su “Avvio” e il file MP4 verrà scritto nella cartella di 

destinazione. 

 

Torna all’indice 

CueMol 

Apriamo CueMol 2.2.3.442 e clicchiamo il menu “File > get PDB using accession code…”. Inseriamo il 

codice “1PRN” e scarichiamo la Porina, una proteina con una struttura a barile beta. Prima di scaricarla 

CueMol ci chiede che aspetto vogliamo assegnare alla molecola. In “Renderer Type” selezioniamo 

“Cartoon” o “Ribbon”. 

Apriamo la sezione “Animation” in basso a sinistra, clicchiamo sul segno + per aggiungere un’animazione e 

scegliamo “Show” in modo che la molecola appaia in 1 secondo con un effetto “dissolvenza”. 



 

Nella finestra “Animation object properties” che si apre, clicchiamo sul segno +, aggiungiamo la molecola 

alla casella “Target renderers” e diamo l’OK. 

 

Ritorniamo alla sezione “Animation”, clicchiamo sul segno + per aggiungere un’animazione e scegliamo 

“Simple spin”. Nella finestra che si apre portiamo la voce “Duration” da 1 a 2 in modo che la rotazione di 

360° avvenga in 2 secondi. 

Alla sezione “Animation”, clicchiamo sul segno + per aggiungere un’ultima animazione e scegliamo “Hide” 

in modo che la molecola al termine della rotazione scompaia in 1 secondo con un effetto “dissolvenza”. 

Nella finestra “Animation object properties” che si apre, clicchiamo sul segno +, aggiungiamo la molecola 

alla casella “Target renderers” e diamo l’OK. 

Prima di creare i frames possiamo testare l’animazione cliccando sulla scheda “Animation” e sul pulsante 

“Play”. Una volta soddisfatti del risultato clicchiamo sul menu “Rendering > animation rendering…”.  

Nella scheda “Main options” selezioniamo la cartella “Output dir:” in cui verranno salvati i frames, 

indichiamo larghezza e altezza dei frames (ad esempio “Preset size 320x240”) e portiamo il framerate a 25 

fps in modo che i 4 secondi dell’animazione producano un totale di 100 frames. 



Nella scheda “Movie option” togliamo il segno di spunta da “Make movie” in modo che una volta generati i 

frames CueMol non tenti di trasformarli automaticamente in un videoclip e poi li cancelli. 

Cliccando infine sul pulsante “Start” CueMol genera i frames PNG utilizzando POV-Ray. Il risultato finale, 

convertendo i frames con Virtualdub2, è il seguente 

Porina_CueMol.mp4 (211 kB) 

***** 

Proviamo ora a costruire una animazione del tipo “Six-Sides mode” di QuteMol con la molecola che ruota 

su 6 lati rimanendo in pausa su ciascun lato. Clicchiamo il menu “File > get PDB using accession code…”. 

Inseriamo il codice “1UBQ” e scarichiamo l’Ubiquitina, una proteina che presenta un avvolgimento 

supersecondario noto come “Rossmann fold”. 

Apriamo la sezione “Animation” in basso a sinistra, clicchiamo sul segno + per aggiungere un’animazione e 

scegliamo “No operation” in modo che la molecola rimanga ferma per 1 secondo. 

Clicchiamo nuovamente sul segno + per aggiungere un’altra animazione e scegliamo “Simple spin”. Nella 

finestra che si apre portiamo la voce “Duration” a 500 ms, la rotazione a 90° e lasciamo il valore 0, 1, 0 su 

“Spin axis” in modo che la prima rotazione avvengo sull’asse Y. 

 

Ripetiamo le due precedenti operazioni, introducendo una pausa di 1 secondo e un’altra rotazione di 90° 

della durata di 500 ms intorno all’asse Y. 

Introduciamo ora un’altra pausa di 1 secondo e una rotazione di 90° della durata di 500 ms intorno all’asse 

X ( il valore di “Spin axis” dovrà essere 1, 0,  0). 

Continuiamo introducendo: pausa – rot. Y – pausa – rot. Y – pausa – rot. X  

Alla fine la sezione “Animation” dovrà avere il seguente aspetto 



 

Clicchiamo sul menu “Rendering > animation rendering…” ed eseguiamo le medesime operazioni viste in 

precedenza. Il risultato finale è il seguente 

Ubiquitina_CueMol.mp4 (235 kB) 

***** 

Costruiamo un’ultima animazione usando una molecola di Acido Acetilsalicilico (Aspirina)  che carichiamo 

con il menu “File > Open file..”. In “Renderer Type” selezioniamo “ballstick” o “cpk”. Nella sezione 

“Animation” in basso a sinistra, clicchiamo sul segno + per aggiungere un’animazione e scegliamo “Slide in” 

in modo che la molecola entri in scena scorrendo. Nella finestra “Animation object properties” che si apre, 

clicchiamo sul segno +, aggiungiamo la molecola alla casella “Target renderers” e diamo l’OK. 

Ritorniamo alla sezione “Animation”, clicchiamo sul segno + per aggiungere un’altra animazione e 

scegliamo “Simple spin”. Nella finestra che si apre portiamo la voce “Duration” da 1 a 2 in modo che la 

rotazione di 360° avvenga in 2 secondi e impostiamo il valore “Spin axis” a 1, 1, 0 su in modo che la 

rotazione avvenga sia sull’asse Y che sull’asse X. 

Diamo l’OK e ritorniamo alla sezione “Animation” per aggiungere un’ultima animazione di tipo “Slide out”. 

Aggiungiamo la molecola alla casella “Target renderers”, impostiamo “direction” su “right” (in modo che la 

molecola esca dalla parte opposta rispetto a dove è entrata) e diamo l’OK. 

Clicchiamo sul menu “Rendering > animation rendering…” ed eseguiamo le medesime operazioni viste in 

precedenza. Il risultato finale è il seguente 

Aspirina_CueMol.mp4 (55 kB) 

Torna all’indice 

MolGif 

Molgif è un programma a riga di comando che converte file molecolari in formato XYZ in GIF animate in 

rotazione. Per usare Molgif è necessario avviare la Shell (o Prompt) a riga di comando di Windows 

(cmd.exe). Da menu “Start” (icona in basso a sinistra del Desktop di Windows) clicchiamo su “Esegui” ( o 

combinazione di tasti Win+R da tastiera). Nella finestra che si apre digitiamo “cmd” e diamo l’OK. 



 

La Shell si apre con attiva la cartella “c:\Users\Administrator”. Se abbiamo messo Molgif.exe sul desktop 

assieme al file xyz da convertire, dobbiamo spostarci sul Desktop digitando “cd desktop” + Invio. 

 

A questo punto dobbiamo procurarci un file molecolare in formato XYZ. Il modo più semplice è ottenerlo in 

qualche altro formato (con uno dei metodi che abbiamo visto in precedenza)  e poi convertirlo in XYZ con 

uno dei tanti programmi che salva in formato XYZ (VMD, OpenBabel, Accelrys-ViewerLite, Avogadro, IQmol 

etc). Mettiamo dunque una molecola di Morfina in formato XYZ sul desktop e nella Shell scriviamo  

Molgif   morfina.xyz 

 

Il comando genera una gif animata 256x256 pixel a sfondo nero, con la molecola in “Ball&stick” che ruota 

attorno all’asse Y di 360° in 3 secondi con 50 frames al secondo. 

Morfina_B&S_molgif.gif (758 kB) 

Naturalmente la GIF animata può essere convertita in un videoclip mp4 usando Virtualdub2 (con le 

modalità che abbiamo già visto). 



Morfina_B&S_molgif.mp4 (152 kB) 

L’animazione si può personalizzare utilizzando i seguenti flags 

-x             rotazione lungo l’asse X  

-y             rotazione lungo l’asse Y 

-z             rotazione lungo l’asse Z 

-X             rotazione antioraria lungo l’asse X 

-Y             rotazione antioraria lungo l’asse Y 

-Z             rotazione antioraria lungo l’asse Z 

-a float    dimensione degli atomi (default 0.4) 

-d float    dimensione legami (default 0.2) 

-b int        valore della componente blu del colore dello sfondo 

-g int        valore della componente verde del colore dello sfondo  

-r int        valore della componente rossa del colore dello sfondo 

-h int        altezza dell’immagine GIF prodotta (default 256) 

-w int       larghezza dell’immagine GIF prodotta (default 256) 

-l             nascondi la scritta molgif sull’animazione 

-o string      nome del file in uscita 

-p             genera un’immagine in formato PNG 

-t int         durata dell’animazione in secondi (default 3) 

 

Ad esempio, per ottenere una rotazione intorno agli assi x e y e una rappresentazione stick (-a 0.2) usiamo 

il comando  

Molgif   -x -y -a 0.2 morfina.xyz 

Il risultato è il seguente 

Morfina_stick_molgif.gif (647 kB) 

Per ottenere uno sfondo grigio (-b 180 -g 180 -r 180), una dimensione 350x350 (-w 350 -h 350) e una durata 

di 4 secondi (-t 4) una rotazione intorno a X (-x) e assenza di logo (-l) usiamo il seguente comando 

Molgif -b 180 -g 180 -r 180 -w 350 -h 350 -t 4 -x -l -a 0.2 morfina.xyz 

L’animazione (convertita in mp4) è la seguente 

Morfina_B&S_4s_molgif.mp4 (294 kB) 

Torna all’indice 

NOC 

NOC è un software per la per la visualizzazione, la validazione e l'analisi delle strutture proteiche in grado di 

creare animazioni di traiettorie prodotte da GROMACS e AMBER e di generare anche semplici animazioni di 

molecole in rotazione. 

Utilizziamo i file GRO  e TRR che abbiamo ottenuto eseguendo una simulazione di Dinamica molecolare con 

Zephyr-Gromacs sul peptide 1fme.pdb. 



Apriamo NOC 3.0.1 e clicchiamo sul menu “Open > Open Gromacs files”. Nella finestra che si apre  

carichiamo il file “1fme_processed.box.em.md.gro” e il file traiettoria “1fme_processed.box.em.md.trr”. 

 

Assieme alla molecola compare anche il pannello “Trajectory Panel”. 

Dal menu “Display” togliamo il segno di spunta da “Show reference mol” in modo che non si sovrapponga 

la molecola iniziale (contenuta nel file GRO) con quelle della traiettoria.  

Dal pannello flottante “Main Panel” sulla sinistra scegliamo “Secondary structure type” oppure “Motif 

type” e impostiamo la qualità su “Best”. 

 

Se non vogliamo che siano visualizzate le catene laterali togliamo tutti i segni di spunta dal menu “Side 

Chain”. Se non vogliamo che siano visualizzati gli assi togliamo il segno di spunta dal menu “Display > Show 

3d Axis”. Se nella proteina sono presenti molecole d’acqua e non vogliamo che siano visualizzate, togliamo 

il segno di spunta dal menu “Display > Water..”.  Se non vogliamo che nell’animazione compaia il 

diagramma di Ramachandran e i FPS togliamo il segno di spunta dai menu “Display > Rama.plot” e “Help > 

Show rendering speed”. 

Dal menu “MainChain” selezioniamo “Ribbon(Cartoon)” e deselezioniamo tutto il resto.  

Aggiustiamo le dimensioni della finestra (l’animazione avrà le dimensioni della finestra). 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione (Clic sinistro + trascina) 

- Zoom (rotella) 

- Traslazione (“shift + clic sinistro + trascina”)  



Dal pannello “Trajectory panel” clicchiamo su “Advance..> Make trajectories movie”. NOC produce un file 

in formato MPEG-1, obsoleto e piuttosto pesante che può essere ricodificato in mp4 usando diversi 

software freeware. Uno dei migliori e più efficienti è XMediaRecode. Il risultato è il seguente 

1fme_NOC.mp4 (202 kB) 

***** 

Ora proviamo ad utilizzare una traiettoria CRD prodotta da AMBER tramite Molby. Utilizziamo la molecola 

di Etanolo costruita con Gabedit in conformazione eclissata, con l’ossidrile con un errato angolo di legame 

di 180° e l’atomo di Idrogeno opposto all’ossidrile che presenta un legame C-H troppo lungo.  

 

Apriamo Molby e carichiamo la molecola con il menu “File > open…” 

 

Clicchiamo sul menu “MM/MD > Guess MM/MD parameters..” e poi su “MM/MD > Molecular 

Dynamics..”. Ora salviamo la traiettoria in formato CRD da menu “File > Export..” scegliendo come tipo di 

file da salvare in “Salva come: AMBER mdcrd file”. 

Infine dobbiamo salvare un file topologia cliccando sul menu “MM/MD > Create SANDER input..”. Il file 

verrà salvato con estensione “PRMTOP”, ma, una volta salvato, lo rinomineremo con estensione “TOP”, in 

modo che NOC possa riconoscerlo e caricarlo. 

Apriamo ora NOC e clicchiamo sul menu “Open > Open Amber files”. Nella finestra che si apre  carichiamo 

il file “etanolo.top” e il file traiettoria “etanolo.crd”. 

 



 

 

Dal menu “Display” selezioniamo “Hetgroup in stick”. Dal pannello “Trajectory panel” clicchiamo su 

“Advance..> Make trajectories movie” e salviamo l’animazione in MPEG. Ricodificando come in precedenza 

il file mpeg con XMediaRecode, il risultato è il seguente 

Etanolo_NOC.mp4 (151 kB) 

***** 

Infine costruiamo un videoclip con una rotazione di una molecola qualsiasi, ad esempio la Fluoxetina, un 

antidepressivo. Possiamo scaricarla da PubChem usando l’opzione “Fetch” di Chimera. Una veloce ricerca in 

rete immettendo “Fluoxetina PubChem cid” ci fornisce il codice “3386”. Una volta scaricato il file con 

Chimera lo salviamo in formato PDB e lo carichiamo con NOC dal menu “File > open molecule”. Dal menu 

“Display” di NOC selezioniamo “Hetgroup in stick”. Clicchiamo infine sul menu “File > Make movie” e NOC 

salverà un videoclip MPEG con la molecola in rotazione. Di seguito il file convertito in MP4 

Fluoxetina_NOC.mp4 (149 kB) 

Torna all’indice 

Discovery Studio Visualizer 

Discovery Studio 3.5 è un software della Accelrys (ora Biovia), liberamente scaricabile previa registrazione, 

che consente (tra l’altro) di utilizzare un editor per costruire molecole e di ottenere buone animazioni in 

formato WebM (codec VP8). Discovery Studio ha anche la caratteristica di visualizzare correttamente i 

legami multipli e gli anelli aromatici in molecole in formato PDB che di solito non hanno questa possibilità. 

Proviamo allora a costruire una molecola di Acido benzoico e successivamente ad animarla. 

Apriamo Discovery Studio, clicchiamo sul menu “File > New > Molecule Window” per aprire la finestra 

dell’editor e infine clicchiamo sulla scheda “Small Molecules”. Sul pannello “Tools”  posto a sinistra 

clicchiamo per aprire il menu “Sketch Molecules”. Per disegnare un anello carbonioso clicchiamo sul 

pulsante “Ring”.   



 

Facendo ora un “clic sinistro” sulla finestra di visualizzazione si ottiene un ciclo saturo a 6 atomi di carbonio 

(cicloesano senza idrogeni). Se invece si vuole un ciclo  con un diverso numero di atomi di Carbonio e 

necessario eseguire un “clic sinistro + trascina” e rilasciare il pulsante del mouse quando si è raggiunto il 

numero desiderato di atomi di carbonio. Per ottenere un anello aromatico (come quello che ci serve per 

l’Acido benzoico) bisogna eseguire le stesse operazione tenendo premuto il tasto Ctrl sulla tastiera. E quindi 

facciamo un “Ctrl + clic sinistro”. Ottenuto l’anello aromatico clicchiamo sul pulsante “H Adds” per 

aggiungere gli atomi di idrogeno ed ottenere una molecola di Benzene. 

 

Ora dobbiamo sostituire un atomo di idrogeno con un gruppo carbossilico –COOH. Clicchiamo dunque su 

un atomo di Idrogeno per selezionarlo (si colorerà di giallo) e clicchiamo sul pulsante “Periodic Table” per 

aprire la tabella degli elementi e cliccare sul Carbonio in modo  che l’atomo di H selezionato venga 

sostituito da un atomo di C. 



 

Ora selezioniamo nel pannello Tools a sinistra lo strumento “Sketch” e disegniamo con un “clic sinistro + 

trascina” un legame C-C. Lo strumento permette di creare una sequenza di legami C-C rilasciando il 

pulsante sinistro del mouse e ripetendo l’operazione di “clic sinistro + trascina”. Per terminare è necessario 

un “doppio clic sinistro”. 

 

Ripetiamo l’operazione per creare un secondo legame C-C. 

 

Ora trasformiamo i due atomi di Carbonio appena inseriti in due atomi di Ossigeno. Clicchiamo sul pulsante 

“Select” e tenendo premuto il tasto “Shift” sulla tastiera” clicchiamo in successione sui due atomi di 

carbonio per selezionarli. Ora clicchiamo sul pulsante “Periodic Table” per aprire la tabella degli elementi e 

cliccare sull’Ossigeno in modo  che i due atomi di C selezionati vengano sostituito dall’Ossigeno. 

Ora riselezioniamo lo strumento “Sketch” e clicchiamo su uno dei due legami C-O per trasformarlo da 

semplice in doppio. 



 

Clicchiamo ora sul pulsante “H Adds” per aggiungere un atomo di Idrogeno all’altro atomo di Ossigeno 

trasformandolo in un Osssidrile. Completiamo il tutto cliccando su “Clean Geometry” in modo da 

ottimizzare la geometria della molecola. 

 

In realtà l’introduzione di un gruppo carbossile (o di altri gruppi chimici) poteva esser fatto in modo più 

semplice e rapido usando il menu “Build fragments” presente sempre a sinistra sul pannello “Tools”. 

Una volta costruita la molecola di Benzene come fatto in precedenza, clicchiamo su un suo atomo di 

Idrogeno per selezionarlo e apriamo il pannello “Build fragments”. Qui compariranno delle cartelle con i 

diversi tipi di frammenti molecolari utilizzabili. Apriamo la cartella “Groups” e selezioniamo “Carboxyl” 



 

Cliccando infine su “Add Fragment” il carbossile si sostituirà all’atomo di Idrogeno selezionato nel Benzene, 

formando l’Acido Benzoico. 

 

Ora la molecola è pronta per un’animazione. Ma prima possiamo modificarne l’aspetto con il menu “View > 

Display style”. La finestra che si apre presenta quattro schede che ci permettono si scegliere oltre che il 

tipo di rappresentazione (Stick, Ball and stick etc) anche il tipo di materiale ( metallico, plastico, opaco etc) 

con cui è costruita la molecola  



 

Ora apriamo lo “Storyboard” per costruire l’animazione cliccando sul menu “View > Storyboard > 

Storyboard” (o semplicemente premendo il tasto F12 da tastiera). Nella finestra che si apre clicchiamo sul 

pulsante “more..” per visualizzare (e modificare) la durata delle transizioni. Ora inseriamo la prima scena 

premendo da tastiera il tasto “Ins”. La scena viene aggiunta allo Storyboard. Modifichiamo la durata della 

transizione portandola a 3 secondi. 

 

Torniamo alla molecola, zoomiamola (tramite la rotella del mouse) portandola in primo piano, e ruotiamola 

in modo che il gruppo carbossilico si avvicini allo spettatore. Ora inseriamo la seconda scena con il tasto 

“Ins” e portiamo la durata della transizione a 3 secondi. 

Ruotiamo la molecola per osservarla da un’altra angolazione e inseriamo la terza scena con il tasto “Ins” 

aggiustando sempre a 3 secondi. 

Ora clicchiamo sulla prima scena della Storyboard in modo che la molecola ritorni alla posizione iniziale. 

Inseriamo nuovamente la prima scena come quarta con il tasto “Ins” in modo che alla fine dell’animazione 

la molecola ritorni nella posizione iniziale e si possa eseguire un loop fluido. 

 



Prima di generare il videoclip è possibile visualizzare l’animazione cliccando sul pulsante “Play” (il 

triangolino nero in basso a sinistra nella Storyboard). Una volta soddisfatti del risultato clicchiamo sul 

pulsante “Export Movie” e salviamo il videoclip in formato WebM con un codec video VP8. 

Il formato WebM può essere facilmente trasformato in MP4 con XmediaRecode. Tuttavia si tratta di un 

formato royalty-free creato in modo specifico per la visualizzazione in rete all’interno di pagine HTML5 e 

quindi può anche essere lasciato così come sta. Di seguito il file ottenuto. 

Benzoico_DSV.webm (386 kB) 

Torna all’indice 

ACD Chemsketch  

Chemsketch 12.0 è un software freeware di modellistica molecolare 2D in grado di creare o modificare 

molecole. Una volta creata la molecola bidimensionale è tuttavia possibile trasferirla al visualizzatore 

tridimensionale (3D viewer) di Chemsketch in grado di ottenere strutture 3D in modo molto efficiente e 

capace di generare semplici GIF animate. 

Apriamo dunque Chemsketch e clicchiamo sul pulsante  “Draw normal” e sul pannello di sinistra 

verifichiamo che sia attivo l’elemento Carbonio (dovrebbero entrambi essere già attivati di default). 

A questo punto un clic sinistro sulla pagina bianca introduce un atomo di carbonio completo dei suoi 4 

idrogeni, una molecola di metano CH4. Un secondo clic sul metano introduce un secondo atomo di 

Carbonio generando una molecola di Etano CH3CH3. 

 

Un “clic sinistro su un legame semplice lo trasforma in doppio, su uno doppio lo trasforma in triplo, su uno 

triplo lo ritrasforma in semplice. 

 

In questo modo possiamo costruire qualsiasi catena carboniosa alifatica (Alcani, alcheni, alchini). 

Se clicchiamo su di un atomo di Carbonio della catena dopo aver selezionato dal pannello di sinistra un 

elemento diverso, l’atomo di C verrà sostituito. 

Ad esempio, se selezioniamo l’Ossigeno e clicchiamo sul gruppo –CH3 dell’Etano, questo verrà sostituito con 

un gruppo ossidrilico -OH, se clicchiamo con L’Azoto avremo in sostituzione un gruppo amminico –NH2. 



 

Chemsketch possiede anche un’interessante funzione di assegnazione del nome IUPAC alla struttura creata, 

tramite menu “Tools > Generate > Name for structure”. 

 

Altre funzioni interessanti sono l’assegnazione alla struttura molecolare della sua notazione SMILES tramite 

menu “Tools > Generate > SMILES Notation” e della sua notazione InChI tramite menu “Tools > Generate > 

InChI for Structure”. 

Proviamo ora a costruire una molecola di Acido fosforico H3PO4 e ad ottenere un’animazione. 

Selezioniamo dal pannello degli elementi sulla sinistra il Fosforo P e clicchiamo sulla pagina bianca. 

Otterremo una molecola di Fosfina PH3. Ora selezioniamo l’Ossigeno ed eseguiamo un “clic sinistro + 

trascina” a partire dalla Fosfina. In questo modo introduciamo un Ossidrile al posto di un atomo di 

Idrogeno della Fosfina. 

 

Ripetiamo l’operazione altre 3 volte in modo che alla fine il Fosforo sia legato a 4 Ossidrili. Clicchiamo su 

uno dei legami semplici che tengono uniti un Ossidrile al Fosforo per trasformarlo in doppio (l’Ossidrile 

perde automaticamente il suo idrogeno). La funzione di assegnazione del nome ci conferma che abbiamo 

ottenuto una molecola di Acido fosforico. 

 



Ora apriamo il visualizzatore 3D cliccando sul menu “ACD/Labs > 3D Viewer”. Il visualizzatore si aprirà 

senza nessuna molecola caricata. Clicchiamo allora sul pulsante “1-ChemSketch” in basso a sinistra per 

tornare a ChemSketch. 

 

Ora sulla finestra di ChemSketch è apparso in basso a sinistra il comando “2-Copy to 3D”. Clicchiamolo in 

modo di trasferire la molecola di acido fosforico al visualizzatore 3D. Usiamo i pulsanti  per 

cambiare l’aspetto della molecola (Wireframe, Sticks, Balls and Sticks, Spacefill). La molecola non presenta 

gli atomi di Idrogeno e ha ovviamente una geometria scorretta. Correggiamo il tutto cliccando sul menu 

“Tools > 3D Optimization”. 

 

Ora generiamo la GIF animata. Clicchiamo sul menu “Tools > New frames Set” per azzerare eventuali 

frames registrati in precedenza e poi su “Tools > Auto Add Frames…”. 

Nella finestra che si apre portiamo il numero di frames a 60 e diamo l’OK. 

 

Clicchiamo ora sul menu “File > Save As…” e nella finestra che si apre scegliamo come tipo di file “Salva 

come: Animated GIF images” 



 

 

L’animazione ottenuta risulta tuttavia troppo lenta e a scatti poiché ogni frame presenta una durata 

eccessiva di 25 ms. È necessario aprire il file GIF con PhotoScape e modificare il delay. Procediamo come 

abbiamo già visto in precedenza. Una volta aperto Photoscape, apriamo la scheda “Tutto per Gif” e 

trasciniamo la Gif animata nella finestra che si apre. Clicchiamo sul pulsante “Cambia tempi” e portiamo la 

durata dei frames ad un valore compreso tra 5 e 10 ms a seconda della velocità di rotazione che vogliamo 

ottenere (selezionando l’opzione “Cambia il display del tempo di tutti i frames”). Infine salviamo la nuova 

GIF animata che ora risulterà più fluida. Il videoclip seguente presenta un delay per frame di 5 ms. 

Fosforico_ChemSketch.gif (138 kB) 

Torna all’indice 

CYLview 

CYLview è in grado di produrre animazioni complesse generando fotogrammi tramite il software freeware 

di raytracing POVray. In realtà il videoclip finale è un file in formato MPEG-1, obsoleto e piuttosto pesante 

che, tra l’altro, il programma non sempre riesce a generare correttamente. È quindi più conveniente 

procedere alla conversione manuale dei file POV in frames BMP e di questi ultimi in un videoclip MP4 

tramite Virtualdub2. 

Apriamo CYLview e carichiamo una molecola di anidride solforosa SO2 tramite il pulsante “Open..” posto in 

basso a sinistra. Definiamo l’aspetto della molecola cliccando sul pulsante “Style”.  Per poter vedere 

l’effetto delle selezioni sull’aspetto della molecola è necessario ogni volta cliccare sul pulsante “Preview”. 

Per eventuali spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Rotazione in z (Ctrl + Clic sinistro + trascina), 

- Zoom (Clic destro + trascina)  

- Traslazione (clic centrale + trascina) 

Una volta soddisfatti, clicchiamo sul pulsante “Poses” e poi clicchiamo sul pulsante “Add” per aggiungere la 

scena iniziale allo Storyboard (possiamo lasciare il nome “Default” proposto dal programma). 

Clicchiamo sul pulsante “Anim” e sul pannello che si apre selezioniamo “800x600” (lo schermo deve avere 

un rapporto di visualizzazione di 4:3 affinchè i frames generati da POVray non siano distorti). Carichiamo 



l’unica scena che abbiamo precedentemente inserito cliccando sul pulsante “Start pose”. Portiamo la 

durata dell’animazione a 3 secondi nella casella “Duration”. In “Animation Type” possiamo scegliere o la 

rotazione (Rotate) o l’oscillazione (Rock). Scegliamo “Rotate” e portiamo l’angolo di rotazione a 360°. A 

questo punto (lasciando “Anim1” come nome dell’animazione) clicchiamo sul pulsante “Add” e 

verifichiamo il risultato cliccando sul pulsante “Play animation”. 

 

Se l’animazione avviene correttamente, possiamo generare i file POV per ciascun frame cliccando sul 

pulsante “Render Animation”. I file POV vengono generati velocemente in una cartella che CYLview crea 

nella stessa posizione in cui è presente la molecola. A questo punto il programma ci chiede se vogliamo 

proseguire e convertire i file POV in frames e i frames in videoclip o se vogliamo semplicemente conservare 

i file POV. Come abbiamo già detto è preferibile eseguire manualmente la conversione (anche perché in 

questo modo possiamo definire la risoluzione finale dei frames). Clicchiamo pertanto sul pulsante “Keep 

POV files”. 

Apriamo POVray e dal menu “Render” mettiamo un segno di spunta su “Auto renderer” in modo che i file 

POV che andremo a caricare vengano trasformati automaticamente in immagini (frames) senza dover dare 

il comando per ognuno di essi. Dal menu a tendina in alto a sinistra scegliamo la risoluzione che dovrà avere 

ciascun frame (e quindi anche il videoclip che poi costruiremo). È necessario mantenere il rapporto di 4:3 e 

quindi vanno bene risoluzioni 800x600,  640x480, 512x384, 400x300, 320x240 etc  



 

Clicchiamo ora sul pulsante “Queue” e nella finestra che si aprirà clicchiamo su “Add file”. Cerchiamo la 

cartella in cui sono presenti i file POV, selezioniamoli tutti (“Clic sinistro” sul primo file e “Shift + clic 

sinistro” sull’ultimo) e diamo l’OK. 

 

Una volta generati i frames sarà sufficiente caricare il primo frame con Virtualdub2 per generare il videoclip 

mp4 come abbiamo già visto. Il risultato è il seguente 

Solforosa_CYLview.mp4 (65 kB) 

La seguente è invece una molecola di Fosfina PH3 con stile “Houkmol” e “Animation type = Rock (45°)” 

Fosfina_CYLview.mp4 (64 kB) 

Proviamo ora a costruire un’animazione complessa, formata da più scene (poses) in cui CYLview si 

preoccupa di costruire i movimenti tra una scena e l’altra in modo fluido. Usiamo l’amminoacido Cisteina. 

Possiamo procurarcelo ad esempio con Avogadro tramite il menu “Build > Insert > Fragments…” e poi 

salvarlo in formato XYZ, nativamente accettato da CYLview (ma se nel PC è installato OpenBabel CYLview lo 

utilizza automaticamente per caricare e convertire tutti i formati riconosciuti da OpenBabel). 

Dopo aver caricato la molecola ed averne definito la posizione iniziale e l’aspetto (Style) andiamo al menu 

“Poses” e aggiungiamo la scena iniziale chiamandola “Scena1”. Ora zoomiamo sulla molecola, portiamo in 

primo piano il gruppo carbossilico e aggiungiamo la scena chiamandola “Scena2”. Portiamo in primo piano 



il gruppo amminico e aggiungiamo la scena chiamandola “Scena3”. Infine portiamo in primo piano il gruppo 

solfidrilico e aggiungiamo la scena chiamandola “Scena4”. 

 

Ora passiamo al menu “Anim” e su “Animation type” selezioniamo “Custom”. Clicchiamo su “Start pose” e 

carichiamo la “Scena1”. Clicchiamo su “End Pose” e carichiamo la “Scena2”. Fissiamo una durata di 1 

secondo e una pausa (Pause) di 1 secondo. Clicchiamo su “Add” per aggiungere l’animazione con il nome di 

“Anim1”. 

 

Ora ripetiamo le operazioni caricando su “Start pose” la “Scena2” e su “End Pose” la “Scena3”, 

aggiungendo l’animazione come “Anim2”. 

Ripetiamo ancora caricando su “Start pose” la “Scena3” e su “End Pose” la “Scena4”, aggiungendo 

l’animazione come “Anim3”. 

E infine carichiamo su “Start pose” la “Scena4” e su “End Pose”  la “Scena1” (in modo che l’animazione 

termini con la scena finale ed il loop sia fluido) aggiungendo l’animazione come “Anim4”. 



 

Dopo aver verificato il risultato con il pulsante “Play animation”, clicchiamo su “Render animation”. In 

questo caso CYLview non genera tutti i frames associati alle pause (che sono ovviamente tutti uguali). Se 

quindi cerchiamo di effettuare noi la conversione dei frames in un videoclip con Virtualdub2 non otteniamo 

l’animazione desiderata. Lasciamo dunque che CYLview completi la conversione e generi il videoclip in 

formato MPEG-1. Possiamo poi caricare il videoclip con Virtualdub2 (o con Xmedia Recode) e convertirlo in 

MP4 (usando ad esempio il filtro “Resize” per diminuirne le dimensioni rispetto alla risoluzione 800x600). 

Il risultato è il seguente 

Cisteina_CYLview.mp4 (265 kB) 

***** 

CYLview è in grado di caricare e animare anche traiettorie in formato XYZ come quelle generate da MoCalc 

(tramite i programmi di Dinamica molecolare Mopac, Firefly e NWChem). Carichiamo ad esempio con 

CYLview la traiettoria di ottimizzazione in formato XYZ ottenuta con MoCalc-Firefly a partire dalla molecola 

di Etanolo in conformazione eclissata, con l’ossidrile con un errato angolo di legame di 180° e l’atomo di 

Idrogeno opposto all’ossidrile che presenta un legame C-H troppo lungo. 

Come è successo con altri programmi (IQmol ad esempio), CYLview non riesce a leggere correttamente il 

legame C-H troppo lungo e lascia l’atomo di idrogeno isolato. 



 

Dopo aver  definito la posizione iniziale e l’aspetto (Style) della molecola, andiamo al menu “Scan” e 

clicchiamo sul pulsante “Make Movie”. Alla fine clicchiamo su “Keep POV files” ed effettuiamo la 

conversione con POVray. 

 

Carichiamo infine i frames con Virtualdub2 per generare il videoclip mp4 come abbiamo già visto. Il 

risultato è il seguente 

Etanolo_CYLview.mp4 (43 kB) 

***** 

Proviamo infine ad usare VMD per convertire in formato XYZ la traiettoria di ottimizzazione dell’acido 2-

Amminobutanoico in formato  CRD ottenuta con Molby. Apriamo VMD e carichiamo prima il file PSF dell’ 

dell’acido 2-Amminobutanoico (che avevamo salvato con Molby) e poi la corrispondente traiettoria CRD. 

Facciamo un clic destro sul nome del file caricato e clicchiamo su “Save coordinates” 



 

 

Nella finestra “Save trajectory” che si apre selezioniamo “File type = xyz” e salviamo. 

 

Apriamo ora la traiettoria XYZ salvata con CYLview e, dopo aver  definito la posizione iniziale e l’aspetto 

(Style) della molecola, andiamo al menu “Scan” e clicchiamo sul pulsante “Make Movie”. Convertiamo i file 

POV con Povray e usiamo i frames ottenuti per creare un videoclip MP4 con Virtualdub2.  

Il risultato è il seguente 

2-amminobutanoico_CYLview.mp4 (336 kB) 

Torna all’indice 

PMV (Python Molecular Viewer) 

PMV 1.5.6 (MGLTools) è un software in grado di produrre animazioni molecolari in modo semplice e veloce, 

utilizzando metodi diversi. 

Apriamo PMV 1.5.6 ed utilizziamo la funzione “Fetch” per scaricare dal database PDB la proteina  

Diidrofolato reduttasi, un enzima che riduce l'acido diidrofolico a tetraidrofolico (forma attiva dell’acido 

folico), usando il coenzima NADPH come donatore di elettroni. Clicchiamo sul menu “File > Import > Fetch 

From Web”, inseriamo il codice PDB = 8DFR e diamo l’OK. La molecola viene scaricata dalla rete e 

visualizzata in modalità “wireframe”.  

Sul riquadro di sinistra (Dashboard) clicchiamo sul pallino rosso per deselezionare la visualizzazione 

“wireframe” (la molecola sparisce) 



 

 Clicchiamo poi sul quarto pallino (che da bianco diventerà rosso) per attivare la visualizzazione in modalità 

“ribbon”. 

 

Clicchiamo sull’ultimo triangolino e dal menu a comparsa scegliamo “Color Scheme – By secondary 

structure”. 

 

Clicchiamo sul triangolino accanto al nome della molecola per far comparire la lista degli aminoacidi 

contenuti nella proteina. 



 

Scorriamo la lista verso il basso fino a trovare la molecola di coenzima NADP (siglata NDP191) e clicchiamo 

sul secondo pallino in modo da attivarne la visualizzazione in “Ball & Stick”. 

 

Aggiustiamo la posizione della molecola (quella che dovrà avere all’inizio dell’animazione). 

Per gli spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione in x o y (Clic sinistro + trascina) 

- Rotazione in z (Ctrl + Clic sinistro + trascina), 

- Zoom (rotella centrale)  

- Traslazione (clic destro + trascina) 

Clicchiamo ora sulla scheda “Animol” (che si trova a destra della scheda “Dashboard”). Clicchiamo sulla 

scheda “Snapshot” e poi sul pulsante “ Record Snapshot” per memorizzare la prima scena. 

 



Ora modifichiamo la posizione della molecola portandola a quella che dovrà essere la seconda scena. Ad 

esempio zoomiamo, portiamo il NADP in primo piano e clicchiamo nuovamente su “ Record Snapshot” per 

memorizzare la seconda scena. 

Facciamo un “clic sinistro” sull’icona della prima scena (per renderla attiva) e poi un “clic destro” e dal 

menu a comparsa clicchiamo su “Add to animation”  

 

Facciamo un “clic sinistro” sull’icona della seconda scena (per renderla attiva) e poi un “clic destro” e dal 

menu a comparsa clicchiamo su “Add to animation”. 

Infine ripetiamo la prima operazione aggiungendo nuovamente la prima scena all’animazione, in modo che 

dopo aver zoomato sul NADP l’animazione ritorni alla scena iniziale per un loop fluido.  

Clicchiamo ora sulla scheda “Sequence Anim” dove dovremmo ritrovare le tre scene inserite in sequenza. 

 

Scorriamo fino in fondo alla scheda “Sequence Anim” dove troveremo i tasti per provare l’animazione con 

un “Play”. Una volta soddisfatti clicchiamo sul tasto “Record”. 

 



PMV genera un file in formato MPEG-2, obsoleto e di grandi dimensioni che possiamo convertire in MP4 

con Virtualdub2 (o XMedia Recode). Il risultato è il seguente 

DHFR_PMV.mp4 (353 kB) 

***** 

PMV permette di costruire animazioni anche utilizzando effetti predefiniti. Utilizziamo la funzione “Fetch” 

per scaricare la Green Fluorescent Protein (PDB = 1EMA), una piccola proteina con una struttura “barile 

beta” espressa nella medusa Aequorea victoria.  La proteina contiene all’interno del barile beta un 

tripeptide (3 aminoacidi) responsabile della fluorescenza verde che caratterizza la proteina (cromoforo). 

Procediamo come abbiamo fatto in precedenza per disattivare la visualizzazione “wireframe” e attivare la 

modalità in modalità “ribbon” con “Color Scheme – By secondary structure”. 

Clicchiamo sul triangolino accanto al nome della molecola per far comparire la lista degli aminoacidi 

contenuti nella proteina. Scorriamo la lista verso il basso fino a trovare il tripeptide (siglato CRO66) e 

clicchiamo sul secondo pallino in modo da attivarne la visualizzazione in “Ball & Stick”. 

Procediamo come prima, Cliccando sulla scheda “Animol”, poi sulla scheda “Snapshot” e infine sul pulsante 

“ Record Snapshot” per memorizzare la prima scena. Zoomiamo, portiamo il cromoforo in primo piano e 

clicchiamo nuovamente su “ Record Snapshot” per memorizzare la seconda scena. 

Ora, con la prima scena visualizzata, clicchiamo sulla scheda “Move” dove troviamo degli effetti predefiniti 

e clicchiamo sul pulsante “Fade In”. 

 

Scendiamo alla fine della scheda fino a trovare l’effetto “Fadein1” inserito nella sezione “Created Action”. 

Facciamo un “clic destro” sull’effetto e clicchiamo su “Add to animation”. 

Ora torniamo alla scheda “Animol > Snapshot”, clicchiamo sulla seconda scena (per renderla attiva) e poi 

un “clic destro” e dal menu a comparsa clicchiamo su “Add to animation”. 

Torniamo alla scheda “Move”, clicchiamo sul pulsante “Rotate”. Scendiamo alla fine della scheda fino a 

trovare l’effetto “Rotate1” inserito nella sezione “Created Action”. Facciamo un “clic destro” sull’effetto e 

clicchiamo su “Add to animation”. 



Torniamo alla scheda “Animol > Snapshot”, clicchiamo sulla prima scena (per renderla attiva) e poi un “clic 

destro” e dal menu a comparsa clicchiamo su “Add to animation”, in modo che, alla fine della rotazione 

intorno al cromoforo portato in primo piano, l’animazione ritorni alla scena iniziale. 

Torniamo ancora alla scheda “Move”, clicchiamo sul pulsante “Fade out”. Scendiamo alla fine della scheda 

fino a trovare l’effetto “Fadeout2” inserito nella sezione “Created Action”. Facciamo un “clic destro” 

sull’effetto e clicchiamo su “Add to animation”. 

Andiamo alla scheda “Sequence anim” che riporta tutti gli effetti in sequenza che abbiamo inserito 

 

Scorriamo fino in fondo alla scheda “Sequence Anim” dove troveremo i tasti per provare l’animazione con 

un “Play”. Una volta soddisfatti clicchiamo sul tasto “Record”. 

Il risultato è il seguente 

1EMA_PMV.mp4 (448 kB) 

Il videoclip seguente è invece una molecola di Nicotina che utilizza in sequenza gli effetti “Fly in” “Rotate” e 

Fly out”. 

Nicotina_PMV.mp4 (376 kB) 

Torna all’indice 

Yasara 

Yasara  è un software liberamente scaricabile previa registrazione, che consente (tra l’altro) di utilizzare 

POVray per ottenere animazioni in formato GIF o MPEG-1. In entrambi i casi si tratta di formati che 

generano file ingombranti e poco efficienti. Sfortunatamente non c’è la possibilità di utilizzare i frames 

generati da POVray per costruire le animazioni autonomamente, poiché Yasara cancella i frames alla fine 

della generazione del videoclip. L’unico modo per non fargli cancellare i frames è di impedirgli di usare i 

programmi per la conversione dei frames in video. Yasara usa a questo scopo i programmi “Convert.exe” e 

“FFMPEG.exe” che si trovano nella cartella “img”. È sufficiente dare a questi due file un nome diverso (o 

semplicemente cancellarli se pensiamo che non ci occorreranno più) e quando Yasara avrà terminato di 

generare i frames in formato PNG (all’interno della cartella “png”) ci avviserà di non poter procedere con la 

loro conversione, ma non li cancellerà.  

Apriamo Yasara ed utilizziamo la funzione “Fetch” per scaricare la proteina Crambina (1CRN). Clicchiamo sul 

menu “File > Load > PDB file from internet”, inseriamo “1CRN” e diamo l’OK. La proteina viene visualizzata 

in modalità “Spacefill”.  Modifichiamone l’aspetto cliccando sul menu “View > Scene style > Ribbon”. 

Aggiustiamo la posizione della molecola (quella che dovrà avere all’inizio dell’animazione). 



Per gli spostamenti della molecola i comandi del mouse sono i seguenti 

- Rotazione (Clic sinistro + trascina) 

- Zoom (clic destro + trascina) 

- Traslazione (Clic sinistro/destro + trascina) 

 

Clicchiamo ora sul menu “File > Save as > Animated GIF/MPEG clip”. Diamo un nome al file finale (se 

usiamo l’estensione .gif verrà creata una GIF animata, se usiamo l’estensione .mpg verrà creato un 

videoclip in formato MPEG-1. Nella finestra successiva, mettiamo un segno di spunta su “Use ray-tracing” e 

nella finestra successiva decidiamo la risoluzione del video (larghezza e altezza). I valori proposti sono 320 x 

240. È necessario mantenere il rapporto di 4:3 e quindi vanno bene risoluzioni 800x600,  640x480, 512x384, 

400x300, 320x240 etc 

Se abbiamo rinominato (o cancellato) i file “Convert.exe” e “FFMPEG.exe” possiamo usare i frames PNG con 

Virtualdub2 per creare un videoclip MP4. 

Il risultato è il seguente. 

Crambina_Yasara.mp4 (244 kB) 

Il videoclip che segue è invece stato ottenuto a partire da una molecola di Fullerene C60 prelevata dalle 

molecole predefinite di Avogadro (menu “Build > Insert > Fragments” sezione “fullerenes”) 

Fullerene_Yasara.mp4 (224 kB) 
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